Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
56 magnus 1
Description: CVE-2018-20020
2
 heap out-of-bound write vulnerability inside structure in VNC client code that
3
 can result remote code execution
4
---
5
 
6
Author: Abhijith PA <abhijith@debian.org>
7
Origin: https://github.com/LibVNC/libvncserver/commit/7b1ef0ffc4815cab9a96c7278394152bdc89dc4d
8
Bug: https://github.com/LibVNC/libvncserver/issues/250
9
Bug-Debian: https://bugs.debian.org/916941
10
Last-Update: 2018-12-23
11
 
12
--- a/vnc_unixsrc/vncviewer/corre.c
13
+++ b/vnc_unixsrc/vncviewer/corre.c
14
@@ -76,7 +76,7 @@
15
     FillRectangle(rx, ry, rw, rh, gcv.foreground);
16
 #endif
17
 
18
-    if (!ReadFromRFBServer(buffer, hdr.nSubrects * (4 + (BPP / 8))))
19
+    if (hdr.nSubrects > BUFFER_SIZE / (4 + (BPP / 8)) || !ReadFromRFBServer(buffer, hdr.nSubrects * (4 + (BPP / 8))))
20
        return False;
21
 
22
     ptr = (CARD8 *)buffer;