Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Blame | Last modification | View Log | RSS feed

Description: CVE-2018-20022
 multiple weaknesses CWE-665: Improper Initialization vulnerability in VNC
 client code that allows attacker to read stack memory and can be abuse for
 information disclosure. Combined with another vulnerability, it can be used
 to leak stack memory layout and in bypassing ASLR
---

Author: Abhijith PA <abhijith@debian.org>
Origin: https://github.com/LibVNC/libvncserver/commit/2f5b2ad1c6c99b1ac6482c95844a84d66bb52838
Bug: https://github.com/LibVNC/libvncserver/issues/252
Bug-Debian: https://bugs.debian.org/916941
Last-Update: 2018-12-23

--- a/vnc_unixsrc/vncviewer/rfbproto.c
+++ b/vnc_unixsrc/vncviewer/rfbproto.c
@@ -2447,6 +2447,7 @@
                }
        }
 
+       memset(&ke, 0, sizeof(ke));
        ke.type = rfbKeyEvent;
        ke.down = down ? 1 : 0;
        ke.key = Swap32IfLE(key);
@@ -2480,6 +2481,7 @@
                return True;
        }
 
+       memset(&cct, 0, sizeof(cct));
        cct.type = rfbClientCutText;
        cct.length = Swap32IfLE((unsigned int) len);
        currentMsg = rfbClientCutText;