Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
58 magnus 1
Description: Replace Imake Makefiles with simple makefiles.
2
Author: Helmut Grohne <helmut@subdivi.de>
3
Bug-Debian: https://bugs.debian.org/888009
4
 
5
Index: ssvnc-1.0.29/vnc_unixsrc/libvncauth/GNUmakefile
6
===================================================================
7
--- /dev/null
8
+++ ssvnc-1.0.29/vnc_unixsrc/libvncauth/GNUmakefile
9
@@ -0,0 +1,14 @@
10
+MAINTAINER_CFLAGS += -I. -I../include
11
+RANLIB ?= ranlib
12
+
13
+%.o:%.c
14
+       $(CC) $(MAINTAINER_CFLAGS) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
15
+
16
+libvncauth.a:vncauth.o d3des.o
17
+       $(AR) cq $@ $^
18
+       $(RANLIB) $@
19
+vncauth.o:vncauth.c d3des.h ../include/vncauth.h
20
+d3des.o:d3des.c d3des.h
21
+
22
+clean:
23
+       rm -f libvncauth.a vncauth.o d3des.o
24
Index: ssvnc-1.0.29/Makefile
25
===================================================================
26
--- ssvnc-1.0.29.orig/Makefile
27
+++ ssvnc-1.0.29/Makefile
28
@@ -43,18 +43,14 @@
29
 ARCHIVE = $(JSRC)/ultraftp.jar
30
 
31
 config:
32
-       sh -c 'type xmkmf'
33
        if [ "X$(JSRC)" != "X" ]; then sh -c 'type javac'; fi
34
        if [ "X$(JSRC)" != "X" ]; then sh -c 'type jar'; fi
35
        @echo
36
-       cd $(VSRC)/libvncauth; pwd; xmkmf
37
-       cd $(VSRC)/vncviewer;  pwd; xmkmf
38
-       @echo
39
        @echo Now run: "'make all'"
40
 
41
 all:
42
-       cd $(VSRC)/libvncauth; $(MAKE) EXTRA_DEFINES="$(CPPFLAGS)" CDEBUGFLAGS="$(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)"
43
-       cd $(VSRC)/vncviewer;  $(MAKE) EXTRA_DEFINES="$(CPPFLAGS)" CDEBUGFLAGS="$(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)"
44
+       $(MAKE) -C $(VSRC)/libvncauth
45
+       $(MAKE) -C $(VSRC)/vncviewer
46
        if [ "X$(JSRC)" != "X" ]; then cd $(JSRC); $(MAKE); fi
47
        cd $(PSRC); $(MAKE) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
48
 
49
Index: ssvnc-1.0.29/vnc_unixsrc/vncviewer/GNUmakefile
50
===================================================================
51
--- /dev/null
52
+++ ssvnc-1.0.29/vnc_unixsrc/vncviewer/GNUmakefile
53
@@ -0,0 +1,35 @@
54
+MAINTAINER_CFLAGS += -I../include -I.
55
+
56
+ifneq ($(filter i%86-linux-gnu,$(shell $(CC) -dumpmachine)),)
57
+MAINTAINER_CFLAGS += -DMITSHM
58
+endif
59
+
60
+%.o:%.c
61
+       $(CC) $(MAINTAINER_CFLAGS) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
62
+
63
+SRCS = \
64
+  argsresources.c \
65
+  caps.c \
66
+  colour.c \
67
+  cursor.c \
68
+  desktop.c \
69
+  dialogs.c \
70
+  fullscreen.c \
71
+  listen.c \
72
+  misc.c \
73
+  popup.c \
74
+  rfbproto.c \
75
+  selection.c \
76
+  shm.c \
77
+  sockets.c \
78
+  tunnel.c \
79
+  vncviewer.c
80
+
81
+OBJS = $(SRCS:.c=.o)
82
+LIBS = -lXaw -lXmu -lXt -lXext -lX11 ../libvncauth/libvncauth.a -lz -ljpeg
83
+
84
+vncviewer:$(OBJS)
85
+       $(CC) $(MAINTAINER_CFLAGS) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
86
+
87
+clean:
88
+       rm -f vncviewer $(OBJS)