Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 19 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
19 magnus 1
Author: Magnus Holmgren <holmgren@debian.org>
2
Description: Use hardcoded (and correct for the Debian package) path to ultraftp.jar
3
 if SSVNC_ULTRA_FTP_JAR is unset.
6 magnus 4
 
25 magnus 5
--- a/vnc_unixsrc/vncviewer/argsresources.c
6
+++ b/vnc_unixsrc/vncviewer/argsresources.c
7
@@ -1702,35 +1702,8 @@ GetArgsAndResources(int argc, char **arg
6 magnus 8
                appData.useBGR233 = 0;
9
        }
10
 
11
-       if (getenv("SSVNC_ULTRA_FTP_JAR") == NULL && programName != NULL) {
12
-               int len = strlen(programName) + 200;
13
-               char *q, *jar = (char *) malloc(len);
14
-               
15
-               sprintf(jar, "%s", programName);
16
-               q = strrchr(jar, '/');
17
-               if (q) {
18
-                       struct stat sb;
19
-                       *(q+1) = '\0';
20
-                       strcat(jar, "../lib/ssvnc/util/ultraftp.jar");
21
-                       if (stat(jar, &sb) == 0) {
22
-                               char *put = (char *) malloc(len);
23
-                               sprintf(put, "SSVNC_ULTRA_FTP_JAR=%s", jar);
24
-                               fprintf(stderr, "Setting: %s\n\n", put);
25
-                               putenv(put);
26
-                       } else {
27
-                               sprintf(jar, "%s", programName);
28
-                               q = strrchr(jar, '/');
29
-                               *(q+1) = '\0';
30
-                               strcat(jar, "util/ultraftp.jar");
31
-                               if (stat(jar, &sb) == 0) {
32
-                                       char *put = (char *) malloc(len);
33
-                                       sprintf(put, "SSVNC_ULTRA_FTP_JAR=%s", jar);
34
-                                       fprintf(stderr, "Setting: %s\n\n", put);
35
-                                       putenv(put);
36
-                               }
37
-                       }
38
-               }
39
-               free(jar);
40
+       if (getenv("SSVNC_ULTRA_FTP_JAR") == NULL) {
41
+           putenv("SSVNC_ULTRA_FTP_JAR=/usr/lib/ssvnc/util/ultraftp.jar");
42
        }
43
 
44