Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 4 | Rev 29 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
DESTDIR=$(CURDIR)/debian/ssvnc
13
 
14
configure: configure-stamp
15
configure-stamp:
16
	dh_testdir
17
	$(MAKE) config
18
	touch configure-stamp
19
 
20
build: build-stamp
19 magnus 21
build-stamp: configure-stamp
3 magnus 22
	dh_testdir
23
 
24
	$(MAKE) all
25
 
26
	touch $@
27
 
19 magnus 28
clean: configure-stamp
3 magnus 29
	dh_testdir
30
	dh_testroot
31
	rm -f build-stamp configure-stamp
32
 
33
	$(MAKE) clean
34
	rm vnc_unixsrc/*/Makefile
35
 
36
	dh_clean
37
 
38
install: build
39
	dh_testdir
40
	dh_testroot
41
	dh_prep
42
 
4 magnus 43
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
19 magnus 44
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
45
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
3 magnus 46
 
47
# Build architecture-independent files here.
48
binary-indep:
49
# We have nothing to do by default.
50
 
51
# Build architecture-dependent files here.
52
binary-arch: build install
53
	dh_testdir
54
	dh_testroot
55
	dh_installchangelogs
56
	dh_installdocs
57
	dh_installexamples
58
	dh_installman
59
	dh_link
60
	dh_strip
61
	dh_compress
62
	dh_fixperms
63
	dh_installdeb
64
	dh_shlibdeps
65
	dh_gencontrol
66
	dh_md5sums
67
	dh_builddeb
68
 
69
binary: binary-indep binary-arch
70
.PHONY: build clean binary-indep binary-arch binary install configure