Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 26 | Rev 31 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
DESTDIR=$(CURDIR)/debian/ssvnc
13
 
14
configure: configure-stamp
15
configure-stamp:
16
	dh_testdir
17
	$(MAKE) config
18
	touch configure-stamp
19
 
29 magnus 20
build-indep:
21
 
22
build-arch: build-stamp
19 magnus 23
build-stamp: configure-stamp
3 magnus 24
	dh_testdir
25
 
26
	$(MAKE) all
27
 
28
	touch $@
29
 
29 magnus 30
build: build-arch build-indep
31
 
19 magnus 32
clean: configure-stamp
3 magnus 33
	dh_testdir
34
	dh_testroot
35
	rm -f build-stamp configure-stamp
36
 
37
	$(MAKE) clean
38
	rm vnc_unixsrc/*/Makefile
39
 
40
	dh_clean
41
 
42
install: build
43
	dh_testdir
44
	dh_testroot
45
	dh_prep
46
 
4 magnus 47
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
19 magnus 48
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
49
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
3 magnus 50
 
51
# Build architecture-independent files here.
52
binary-indep:
53
# We have nothing to do by default.
54
 
55
# Build architecture-dependent files here.
56
binary-arch: build install
57
	dh_testdir
58
	dh_testroot
26 magnus 59
	dh_installchangelogs -k ReleaseNotes
3 magnus 60
	dh_installdocs
61
	dh_installexamples
62
	dh_installman
63
	dh_link
64
	dh_strip
65
	dh_compress
66
	dh_fixperms
67
	dh_installdeb
68
	dh_shlibdeps
69
	dh_gencontrol
70
	dh_md5sums
71
	dh_builddeb
72
 
73
binary: binary-indep binary-arch
29 magnus 74
.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install configure