Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 29 | Rev 37 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
DESTDIR=$(CURDIR)/debian/ssvnc
13
 
31 magnus 14
export CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
15
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
16
 
3 magnus 17
configure: configure-stamp
18
configure-stamp:
19
	dh_testdir
20
	$(MAKE) config
21
	touch configure-stamp
22
 
29 magnus 23
build-indep:
24
 
25
build-arch: build-stamp
19 magnus 26
build-stamp: configure-stamp
3 magnus 27
	dh_testdir
28
 
29
	$(MAKE) all
30
 
31
	touch $@
32
 
29 magnus 33
build: build-arch build-indep
34
 
19 magnus 35
clean: configure-stamp
3 magnus 36
	dh_testdir
37
	dh_testroot
38
	rm -f build-stamp configure-stamp
39
 
40
	$(MAKE) clean
41
	rm vnc_unixsrc/*/Makefile
42
 
43
	dh_clean
44
 
45
install: build
46
	dh_testdir
47
	dh_testroot
48
	dh_prep
49
 
4 magnus 50
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
19 magnus 51
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
52
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
3 magnus 53
 
54
# Build architecture-independent files here.
55
binary-indep:
56
# We have nothing to do by default.
57
 
58
# Build architecture-dependent files here.
59
binary-arch: build install
60
	dh_testdir
61
	dh_testroot
26 magnus 62
	dh_installchangelogs -k ReleaseNotes
3 magnus 63
	dh_installdocs
64
	dh_installexamples
65
	dh_installman
66
	dh_link
67
	dh_strip
68
	dh_compress
69
	dh_fixperms
70
	dh_installdeb
71
	dh_shlibdeps
72
	dh_gencontrol
73
	dh_md5sums
74
	dh_builddeb
75
 
76
binary: binary-indep binary-arch
29 magnus 77
.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install configure