Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 51 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
DESTDIR=$(CURDIR)/debian/ssvnc
13
 
37 magnus 14
export CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
31 magnus 15
export CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
16
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
17
 
3 magnus 18
configure: configure-stamp
19
configure-stamp:
20
	dh_testdir
21
	$(MAKE) config
22
	touch configure-stamp
23
 
29 magnus 24
build-indep:
25
 
26
build-arch: build-stamp
19 magnus 27
build-stamp: configure-stamp
3 magnus 28
	dh_testdir
29
 
54 magnus 30
	$(MAKE) all JC_ARGS="-source 1.7 -target 1.7"
3 magnus 31
 
32
	touch $@
33
 
29 magnus 34
build: build-arch build-indep
35
 
19 magnus 36
clean: configure-stamp
3 magnus 37
	dh_testdir
38
	dh_testroot
39
	rm -f build-stamp configure-stamp
40
 
41
	$(MAKE) clean
42
	rm vnc_unixsrc/*/Makefile
43
 
44
	dh_clean
45
 
46
install: build
47
	dh_testdir
48
	dh_testroot
49
	dh_prep
50
 
4 magnus 51
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
19 magnus 52
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
53
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
3 magnus 54
 
55
# Build architecture-independent files here.
56
binary-indep:
57
# We have nothing to do by default.
58
 
59
# Build architecture-dependent files here.
60
binary-arch: build install
61
	dh_testdir
62
	dh_testroot
26 magnus 63
	dh_installchangelogs -k ReleaseNotes
3 magnus 64
	dh_installdocs
65
	dh_installexamples
66
	dh_installman
67
	dh_link
39 magnus 68
	dh_strip_nondeterminism
3 magnus 69
	dh_strip
70
	dh_compress
71
	dh_fixperms
72
	dh_installdeb
73
	dh_shlibdeps
74
	dh_gencontrol
75
	dh_md5sums
76
	dh_builddeb
77
 
78
binary: binary-indep binary-arch
29 magnus 79
.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install configure