Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 4 | Rev 29 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 4 Rev 19
Line 9... Line 9...
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
11
12
DESTDIR=$(CURDIR)/debian/ssvnc
12
DESTDIR=$(CURDIR)/debian/ssvnc
13
13
14
include /usr/share/dpatch/dpatch.make
-
 
15
-
 
16
configure: configure-stamp
14
configure: configure-stamp
17
configure-stamp:
15
configure-stamp:
18
	dh_testdir
16
	dh_testdir
19
	$(MAKE) config
17
	$(MAKE) config
20
	touch configure-stamp
18
	touch configure-stamp
21
19
22
build: build-stamp
20
build: build-stamp
23
build-stamp: configure-stamp patch-stamp
21
build-stamp: configure-stamp
24
	dh_testdir
22
	dh_testdir
25
23
26
	$(MAKE) all
24
	$(MAKE) all
27
25
28
	touch $@
26
	touch $@
29
27
30
clean: configure-stamp unpatch
28
clean: configure-stamp
31
	dh_testdir
29
	dh_testdir
32
	dh_testroot
30
	dh_testroot
33
	rm -f build-stamp configure-stamp
31
	rm -f build-stamp configure-stamp
34
32
35
	$(MAKE) clean
33
	$(MAKE) clean
Line 41... Line 39...
41
	dh_testdir
39
	dh_testdir
42
	dh_testroot
40
	dh_testroot
43
	dh_prep
41
	dh_prep
44
42
45
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
43
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
-
 
44
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
-
 
45
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
46
46
47
# Build architecture-independent files here.
47
# Build architecture-independent files here.
48
binary-indep:
48
binary-indep:
49
# We have nothing to do by default.
49
# We have nothing to do by default.
50
50