Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 19 | Rev 29 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 19 Rev 26
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
8
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
11
12
DESTDIR=$(CURDIR)/debian/ssvnc
12
DESTDIR=$(CURDIR)/debian/ssvnc
13
13
14
configure: configure-stamp
14
configure: configure-stamp
15
configure-stamp:
15
configure-stamp:
16
	dh_testdir
16
	dh_testdir
17
	$(MAKE) config
17
	$(MAKE) config
18
	touch configure-stamp
18
	touch configure-stamp
19
19
20
build: build-stamp
20
build: build-stamp
21
build-stamp: configure-stamp
21
build-stamp: configure-stamp
22
	dh_testdir
22
	dh_testdir
23
23
24
	$(MAKE) all
24
	$(MAKE) all
25
25
26
	touch $@
26
	touch $@
27
27
28
clean: configure-stamp
28
clean: configure-stamp
29
	dh_testdir
29
	dh_testdir
30
	dh_testroot
30
	dh_testroot
31
	rm -f build-stamp configure-stamp
31
	rm -f build-stamp configure-stamp
32
32
33
	$(MAKE) clean
33
	$(MAKE) clean
34
	rm vnc_unixsrc/*/Makefile
34
	rm vnc_unixsrc/*/Makefile
35
35
36
	dh_clean 
36
	dh_clean 
37
37
38
install: build
38
install: build
39
	dh_testdir
39
	dh_testdir
40
	dh_testroot
40
	dh_testroot
41
	dh_prep
41
	dh_prep
42
42
43
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
43
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
44
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
44
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
45
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
45
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
46
46
47
# Build architecture-independent files here.
47
# Build architecture-independent files here.
48
binary-indep:
48
binary-indep:
49
# We have nothing to do by default.
49
# We have nothing to do by default.
50
50
51
# Build architecture-dependent files here.
51
# Build architecture-dependent files here.
52
binary-arch: build install
52
binary-arch: build install
53
	dh_testdir
53
	dh_testdir
54
	dh_testroot
54
	dh_testroot
55
	dh_installchangelogs 
55
	dh_installchangelogs -k ReleaseNotes
56
	dh_installdocs
56
	dh_installdocs
57
	dh_installexamples
57
	dh_installexamples
58
	dh_installman
58
	dh_installman
59
	dh_link
59
	dh_link
60
	dh_strip
60
	dh_strip
61
	dh_compress
61
	dh_compress
62
	dh_fixperms
62
	dh_fixperms
63
	dh_installdeb
63
	dh_installdeb
64
	dh_shlibdeps
64
	dh_shlibdeps
65
	dh_gencontrol
65
	dh_gencontrol
66
	dh_md5sums
66
	dh_md5sums
67
	dh_builddeb
67
	dh_builddeb
68
68
69
binary: binary-indep binary-arch
69
binary: binary-indep binary-arch
70
.PHONY: build clean binary-indep binary-arch binary install configure
70
.PHONY: build clean binary-indep binary-arch binary install configure