Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 26 | Rev 31 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 26 Rev 29
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
8
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
11
12
DESTDIR=$(CURDIR)/debian/ssvnc
12
DESTDIR=$(CURDIR)/debian/ssvnc
13
13
14
configure: configure-stamp
14
configure: configure-stamp
15
configure-stamp:
15
configure-stamp:
16
	dh_testdir
16
	dh_testdir
17
	$(MAKE) config
17
	$(MAKE) config
18
	touch configure-stamp
18
	touch configure-stamp
19
19
-
 
20
build-indep:
-
 
21
20
build: build-stamp
22
build-arch: build-stamp
21
build-stamp: configure-stamp
23
build-stamp: configure-stamp
22
	dh_testdir
24
	dh_testdir
23
25
24
	$(MAKE) all
26
	$(MAKE) all
25
27
26
	touch $@
28
	touch $@
27
29
-
 
30
build: build-arch build-indep
-
 
31
28
clean: configure-stamp
32
clean: configure-stamp
29
	dh_testdir
33
	dh_testdir
30
	dh_testroot
34
	dh_testroot
31
	rm -f build-stamp configure-stamp
35
	rm -f build-stamp configure-stamp
32
36
33
	$(MAKE) clean
37
	$(MAKE) clean
34
	rm vnc_unixsrc/*/Makefile
38
	rm vnc_unixsrc/*/Makefile
35
39
36
	dh_clean 
40
	dh_clean 
37
41
38
install: build
42
install: build
39
	dh_testdir
43
	dh_testdir
40
	dh_testroot
44
	dh_testroot
41
	dh_prep
45
	dh_prep
42
46
43
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
47
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
44
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
48
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
45
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
49
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
46
50
47
# Build architecture-independent files here.
51
# Build architecture-independent files here.
48
binary-indep:
52
binary-indep:
49
# We have nothing to do by default.
53
# We have nothing to do by default.
50
54
51
# Build architecture-dependent files here.
55
# Build architecture-dependent files here.
52
binary-arch: build install
56
binary-arch: build install
53
	dh_testdir
57
	dh_testdir
54
	dh_testroot
58
	dh_testroot
55
	dh_installchangelogs -k ReleaseNotes
59
	dh_installchangelogs -k ReleaseNotes
56
	dh_installdocs
60
	dh_installdocs
57
	dh_installexamples
61
	dh_installexamples
58
	dh_installman
62
	dh_installman
59
	dh_link
63
	dh_link
60
	dh_strip
64
	dh_strip
61
	dh_compress
65
	dh_compress
62
	dh_fixperms
66
	dh_fixperms
63
	dh_installdeb
67
	dh_installdeb
64
	dh_shlibdeps
68
	dh_shlibdeps
65
	dh_gencontrol
69
	dh_gencontrol
66
	dh_md5sums
70
	dh_md5sums
67
	dh_builddeb
71
	dh_builddeb
68
72
69
binary: binary-indep binary-arch
73
binary: binary-indep binary-arch
70
.PHONY: build clean binary-indep binary-arch binary install configure
74
.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install configure