Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 29 | Rev 37 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 29 Rev 31
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
8
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
11
12
DESTDIR=$(CURDIR)/debian/ssvnc
12
DESTDIR=$(CURDIR)/debian/ssvnc
13
13
-
 
14
export CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
-
 
15
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
-
 
16
14
configure: configure-stamp
17
configure: configure-stamp
15
configure-stamp:
18
configure-stamp:
16
	dh_testdir
19
	dh_testdir
17
	$(MAKE) config
20
	$(MAKE) config
18
	touch configure-stamp
21
	touch configure-stamp
19
22
20
build-indep:
23
build-indep:
21
24
22
build-arch: build-stamp
25
build-arch: build-stamp
23
build-stamp: configure-stamp
26
build-stamp: configure-stamp
24
	dh_testdir
27
	dh_testdir
25
28
26
	$(MAKE) all
29
	$(MAKE) all
27
30
28
	touch $@
31
	touch $@
29
32
30
build: build-arch build-indep
33
build: build-arch build-indep
31
34
32
clean: configure-stamp
35
clean: configure-stamp
33
	dh_testdir
36
	dh_testdir
34
	dh_testroot
37
	dh_testroot
35
	rm -f build-stamp configure-stamp
38
	rm -f build-stamp configure-stamp
36
39
37
	$(MAKE) clean
40
	$(MAKE) clean
38
	rm vnc_unixsrc/*/Makefile
41
	rm vnc_unixsrc/*/Makefile
39
42
40
	dh_clean 
43
	dh_clean 
41
44
42
install: build
45
install: build
43
	dh_testdir
46
	dh_testdir
44
	dh_testroot
47
	dh_testroot
45
	dh_prep
48
	dh_prep
46
49
47
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
50
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
48
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
51
	sed -ri -e 's#/bin/sh#/bin/bash#g' \
49
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
52
	 $(addprefix $(DESTDIR)/usr/lib/ssvnc/,ssvnc ssvnc_cmd util/ss_vncviewer util/ssvnc.tcl)
50
53
51
# Build architecture-independent files here.
54
# Build architecture-independent files here.
52
binary-indep:
55
binary-indep:
53
# We have nothing to do by default.
56
# We have nothing to do by default.
54
57
55
# Build architecture-dependent files here.
58
# Build architecture-dependent files here.
56
binary-arch: build install
59
binary-arch: build install
57
	dh_testdir
60
	dh_testdir
58
	dh_testroot
61
	dh_testroot
59
	dh_installchangelogs -k ReleaseNotes
62
	dh_installchangelogs -k ReleaseNotes
60
	dh_installdocs
63
	dh_installdocs
61
	dh_installexamples
64
	dh_installexamples
62
	dh_installman
65
	dh_installman
63
	dh_link
66
	dh_link
64
	dh_strip
67
	dh_strip
65
	dh_compress
68
	dh_compress
66
	dh_fixperms
69
	dh_fixperms
67
	dh_installdeb
70
	dh_installdeb
68
	dh_shlibdeps
71
	dh_shlibdeps
69
	dh_gencontrol
72
	dh_gencontrol
70
	dh_md5sums
73
	dh_md5sums
71
	dh_builddeb
74
	dh_builddeb
72
75
73
binary: binary-indep binary-arch
76
binary: binary-indep binary-arch
74
.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install configure
77
.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install configure