Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Rev 19 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 3 Rev 4
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
8
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
11
12
DESTDIR=$(CURDIR)/debian/ssvnc
12
DESTDIR=$(CURDIR)/debian/ssvnc
13
13
14
include /usr/share/dpatch/dpatch.make
14
include /usr/share/dpatch/dpatch.make
15
15
16
configure: configure-stamp
16
configure: configure-stamp
17
configure-stamp:
17
configure-stamp:
18
	dh_testdir
18
	dh_testdir
19
	$(MAKE) config
19
	$(MAKE) config
20
	touch configure-stamp
20
	touch configure-stamp
21
21
22
build: build-stamp
22
build: build-stamp
23
build-stamp: configure-stamp patch-stamp
23
build-stamp: configure-stamp patch-stamp
24
	dh_testdir
24
	dh_testdir
25
25
26
	$(MAKE) all
26
	$(MAKE) all
27
27
28
	touch $@
28
	touch $@
29
29
30
clean: configure-stamp unpatch
30
clean: configure-stamp unpatch
31
	dh_testdir
31
	dh_testdir
32
	dh_testroot
32
	dh_testroot
33
	rm -f build-stamp configure-stamp
33
	rm -f build-stamp configure-stamp
34
34
35
	$(MAKE) clean
35
	$(MAKE) clean
36
	rm vnc_unixsrc/*/Makefile
36
	rm vnc_unixsrc/*/Makefile
37
37
38
	dh_clean 
38
	dh_clean 
39
39
40
install: build
40
install: build
41
	dh_testdir
41
	dh_testdir
42
	dh_testroot
42
	dh_testroot
43
	dh_prep
43
	dh_prep
44
44
45
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man/man1 install
45
	$(MAKE) ROOT=$(DESTDIR) PREFIX=/usr MANDIR=share/man install
46
46
47
# Build architecture-independent files here.
47
# Build architecture-independent files here.
48
binary-indep:
48
binary-indep:
49
# We have nothing to do by default.
49
# We have nothing to do by default.
50
50
51
# Build architecture-dependent files here.
51
# Build architecture-dependent files here.
52
binary-arch: build install
52
binary-arch: build install
53
	dh_testdir
53
	dh_testdir
54
	dh_testroot
54
	dh_testroot
55
	dh_installchangelogs 
55
	dh_installchangelogs 
56
	dh_installdocs
56
	dh_installdocs
57
	dh_installexamples
57
	dh_installexamples
58
	dh_installman
58
	dh_installman
59
	dh_link
59
	dh_link
60
	dh_strip
60
	dh_strip
61
	dh_compress
61
	dh_compress
62
	dh_fixperms
62
	dh_fixperms
63
	dh_installdeb
63
	dh_installdeb
64
	dh_shlibdeps
64
	dh_shlibdeps
65
	dh_gencontrol
65
	dh_gencontrol
66
	dh_md5sums
66
	dh_md5sums
67
	dh_builddeb
67
	dh_builddeb
68
68
69
binary: binary-indep binary-arch
69
binary: binary-indep binary-arch
70
.PHONY: build clean binary-indep binary-arch binary install configure
70
.PHONY: build clean binary-indep binary-arch binary install configure