Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 14 | Only display areas with differences | Regard whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 14 Rev 17
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# debian/rules for freesweep
2
# debian/rules for freesweep
3
# modifications by Edward Betts <edward@debian.org>
3
# modifications by Edward Betts <edward@debian.org>
4
# Based on:
4
# Based on:
5
# Sample debian/rules that uses debhelper.
5
# Sample debian/rules that uses debhelper.
6
# GNU copyright 1997 to 1999 by Joey Hess.
6
# GNU copyright 1997 to 1999 by Joey Hess.
7
7
8
# Uncomment this to turn on verbose mode.
8
# Uncomment this to turn on verbose mode.
9
#export DH_VERBOSE=1
9
#export DH_VERBOSE=1
10
10
11
# This has to be exported to make some magic below work.
11
# This has to be exported to make some magic below work.
12
export DH_OPTIONS
12
export DH_OPTIONS
13
13
14
config-stamp: configure
14
config-stamp: configure
15
	dh_testdir
15
	dh_testdir
16
	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
16
	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
17
	        --prefix=/usr \
17
	        --prefix=/usr \
18
	        --mandir=\$${prefix}/share/man
18
	        --mandir=\$${prefix}/share/man
19
	touch config-stamp
19
	touch config-stamp
20
20
21
build: build-stamp
21
build: build-stamp
22
build-stamp: config-stamp
22
build-stamp: config-stamp
23
	dh_testdir
23
	dh_testdir
24
24
25
	$(MAKE)
25
	$(MAKE)
26
26
27
	touch build-stamp
27
	touch build-stamp
28
28
29
clean:
29
clean:
30
	dh_testdir
30
	dh_testdir
31
	dh_testroot
31
	dh_testroot
32
	rm -f build-stamp
32
	rm -f build-stamp
33
33
34
	[ ! -f Makefile ] || $(MAKE) clean
34
	[ ! -f Makefile ] || $(MAKE) clean
35
35
36
	dh_clean config-stamp Makefile config.status config.log config.cache
36
	dh_clean config-stamp Makefile config.status config.log config.cache
37
37
38
install: build
38
install: build
39
	dh_testdir
39
	dh_testdir
40
	dh_testroot
40
	dh_testroot
41
	dh_clean -k
41
	dh_clean -k
42
42
43
	install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share
43
	install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share
44
	$(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install
44
	$(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install
45
45
46
# Build architecture-independent files here.
46
# Build architecture-independent files here.
47
binary-indep:
47
binary-indep:
48
# We have nothing to do by default.
48
# We have nothing to do by default.
49
49
50
# Build architecture-dependent files here.
50
# Build architecture-dependent files here.
51
binary-arch: build install
51
binary-arch: build install
52
	dh_testdir
52
	dh_testdir
53
	dh_testroot
53
	dh_testroot
54
	dh_installdocs
54
	dh_installdocs
55
	dh_installexamples
55
	dh_installexamples
56
	dh_installmenu
56
	dh_installmenu
57
#	dh_installmanpages
57
#	dh_installmanpages
58
	dh_installchangelogs
58
	dh_installchangelogs
59
	dh_link
59
	dh_link
60
	dh_strip
60
	dh_strip
61
	dh_compress
61
	dh_compress
62
	dh_fixperms
62
	dh_fixperms
63
	dh_installdeb
63
	dh_installdeb
64
	dh_shlibdeps
64
	dh_shlibdeps
65
	dh_gencontrol
65
	dh_gencontrol
66
	dh_md5sums
66
	dh_md5sums
67
	dh_builddeb
67
	dh_builddeb
68
68
69
binary: binary-indep binary-arch
69
binary: binary-indep binary-arch
70
.PHONY: build clean binary-indep binary-arch binary install
70
.PHONY: build clean binary-indep binary-arch binary install