Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
31 magnus 1
Description: Add missing includes and prototypes
2
 
3
--- a/rfbproto.c
4
+++ b/rfbproto.c
5
@@ -30,6 +30,8 @@
6
 #include <x2vnc.h>
7
 #include <X11/Xatom.h>
8
 #include <vncauth.h>
9
+#include <ctype.h>
10
+#include <time.h>
11
 
12
 static Bool HandleHextileEncoding8(int x, int y, int w, int h);
13
 static Bool HandleHextileEncoding16(int x, int y, int w, int h);
14
--- a/sockets.c
15
+++ b/sockets.c
16
@@ -31,6 +31,7 @@
17
 #include <x2vnc.h>
18
 
19
 void PrintInHex(char *buf, int len);
20
+int tunnel(char *gatewayhost, char *remotehost, int remoteport);
21
 
22
 Bool errorMessageFromReadExact = True;
23
 Bool useSSHTunnel;
24
--- a/vncauth.c
25
+++ b/vncauth.c
26
@@ -24,6 +24,8 @@
27
 #include <stdio.h>
28
 #include <stdlib.h>
29
 #include <string.h>
30
+#include <unistd.h>
31
+#include <time.h>
32
 #include <sys/types.h>
33
 #include <sys/stat.h>
34
 #include <vncauth.h>
35
--- a/x2vnc.c
36
+++ b/x2vnc.c
37
@@ -25,6 +25,7 @@
38
 
39
 #include <unistd.h>
40
 #include <errno.h>
41
+#include <time.h>
42
 #include <sys/types.h>
43
 #include <sys/wait.h>
44
 #include <sys/time.h>
45
--- a/x.c
46
+++ b/x.c
47
@@ -27,6 +27,7 @@
48
 #include <unistd.h>
49
 #include <x2vnc.h>
50
 #include <math.h>
51
+#include <time.h>
52
 #include <X11/X.h>
53
 #include <X11/Xutil.h>
54
 #include <X11/Xatom.h>