Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Blame | Last modification | View Log | RSS feed

Description: Add missing includes and prototypes

--- a/rfbproto.c
+++ b/rfbproto.c
@@ -30,6 +30,8 @@
 #include <x2vnc.h>
 #include <X11/Xatom.h>
 #include <vncauth.h>
+#include <ctype.h>
+#include <time.h>
 
 static Bool HandleHextileEncoding8(int x, int y, int w, int h);
 static Bool HandleHextileEncoding16(int x, int y, int w, int h);
--- a/sockets.c
+++ b/sockets.c
@@ -31,6 +31,7 @@
 #include <x2vnc.h>
 
 void PrintInHex(char *buf, int len);
+int tunnel(char *gatewayhost, char *remotehost, int remoteport);
 
 Bool errorMessageFromReadExact = True;
 Bool useSSHTunnel;
--- a/vncauth.c
+++ b/vncauth.c
@@ -24,6 +24,8 @@
 #include <stdio.h>
 #include <stdlib.h>
 #include <string.h>
+#include <unistd.h>
+#include <time.h>
 #include <sys/types.h>
 #include <sys/stat.h>
 #include <vncauth.h>
--- a/x2vnc.c
+++ b/x2vnc.c
@@ -25,6 +25,7 @@
 
 #include <unistd.h>
 #include <errno.h>
+#include <time.h>
 #include <sys/types.h>
 #include <sys/wait.h>
 #include <sys/time.h>
--- a/x.c
+++ b/x.c
@@ -27,6 +27,7 @@
 #include <unistd.h>
 #include <x2vnc.h>
 #include <math.h>
+#include <time.h>
 #include <X11/X.h>
 #include <X11/Xutil.h>
 #include <X11/Xatom.h>