Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
15 magnus 1
Description: Fix a sticking cursor in a multi-screen configuration
2
 When x2vnc is compiled with Xinerama support and runs with a multiscreen setup,
3
 the cursor can become stuck on the border between the local and remote screens,
4
 not moving further than the border, as it should do.
5
Author: Will Shackleton <w.shackleton@gmail.com>
6
Bug-Debian: http://bugs.debian.org/616396
7
Bug-Ubuntu: https://launchpad.net/bugs/726783
8
Forwarded: yes
9
 
10
--- a/x.c       2008-03-25 10:45:34 +0000
11
+++ b/x.c       2011-03-03 23:34:29 +0000
12
@@ -848,9 +848,9 @@
13
 {
14
   int n,ret=a.x;
15
   if(a.y < ret) ret=a.y;
16
-  n=displayHeight - a.y;
17
+  n=y_offset + displayHeight - a.y;
18
   if(n < ret) ret=n;
19
-  n=displayWidth - a.x;
20
+  n=x_offset + displayWidth - a.x;
21
   if(n < ret) ret=n;
22
   return ret;
23
 }
24