?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Blame |
Last modification |
View Log
| RSS feed
Description: Fix a sticking cursor in a multi-screen configuration
When x2vnc is compiled with Xinerama support and runs with a multiscreen setup,
the cursor can become stuck on the border between the local and remote screens,
not moving further than the border, as it should do.
Author: Will Shackleton <w.shackleton@gmail.com>
Bug-Debian: http://bugs.debian.org/616396
Bug-Ubuntu: https://launchpad.net/bugs/726783
Forwarded: yes
--- a/x.c 2008-03-25 10:45:34 +0000
+++ b/x.c 2011-03-03 23:34:29 +0000
@@ -848,9 +848,9 @@
{
int n,ret=a.x;
if(a.y < ret) ret=a.y;
- n=displayHeight - a.y;
+ n=y_offset + displayHeight - a.y;
if(n < ret) ret=n;
- n=displayWidth - a.x;
+ n=x_offset + displayWidth - a.x;
if(n < ret) ret=n;
return ret;
}