Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 14 | Rev 22 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 14 Rev 21
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# debian/rules for freesweep
2
# debian/rules for freesweep
3
# modifications by Edward Betts <edward@debian.org>
3
# modifications by Edward Betts <edward@debian.org>
4
# Based on:
4
# Based on:
5
# Sample debian/rules that uses debhelper.
5
# Sample debian/rules that uses debhelper.
6
# GNU copyright 1997 to 1999 by Joey Hess.
6
# GNU copyright 1997 to 1999 by Joey Hess.
7
7
8
# Uncomment this to turn on verbose mode.
8
# Uncomment this to turn on verbose mode.
9
#export DH_VERBOSE=1
9
#export DH_VERBOSE=1
10
10
11
# This has to be exported to make some magic below work.
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-
 
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
 
13
12
export DH_OPTIONS
14
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
-
 
15
  buildflags = --build=$(DEB_BUILD_GNU_TYPE)
-
 
16
else
-
 
17
  buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
-
 
18
endif
13
19
14
config-stamp: configure
20
config-stamp: configure
15
	dh_testdir
21
	dh_testdir
16
	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
22
	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
17
	        --prefix=/usr \
23
	        --prefix=/usr \
18
	        --mandir=\$${prefix}/share/man
24
	        --mandir=\$${prefix}/share/man \
-
 
25
	        $(shell dpkg-buildflags --export=configure)
19
	touch config-stamp
26
	touch config-stamp
20
27
21
build: build-stamp
28
build: build-stamp
22
build-stamp: config-stamp
29
build-stamp: config-stamp
23
	dh_testdir
30
	dh_testdir
24
31
25
	$(MAKE)
32
	$(MAKE)
26
33
27
	touch build-stamp
34
	touch build-stamp
28
35
29
clean:
36
clean:
30
	dh_testdir
37
	dh_testdir
31
	dh_testroot
38
	dh_testroot
32
	rm -f build-stamp
39
	rm -f build-stamp
33
40
34
	[ ! -f Makefile ] || $(MAKE) clean
41
	[ ! -f Makefile ] || $(MAKE) clean
35
42
36
	dh_clean config-stamp Makefile config.status config.log config.cache
43
	dh_clean config-stamp Makefile config.status config.log config.cache
37
44
38
install: build
45
install: build
39
	dh_testdir
46
	dh_testdir
40
	dh_testroot
47
	dh_testroot
41
	dh_clean -k
48
	dh_clean -k
42
49
43
	install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share
50
	install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share
44
	$(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install
51
	$(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install
45
52
46
# Build architecture-independent files here.
53
# Build architecture-independent files here.
47
binary-indep:
54
binary-indep:
48
# We have nothing to do by default.
55
# We have nothing to do by default.
49
56
50
# Build architecture-dependent files here.
57
# Build architecture-dependent files here.
51
binary-arch: build install
58
binary-arch: build install
52
	dh_testdir
59
	dh_testdir
53
	dh_testroot
60
	dh_testroot
54
	dh_installdocs
61
	dh_installdocs
55
	dh_installexamples
62
	dh_installexamples
56
	dh_installmenu
63
	dh_installmenu
57
#	dh_installmanpages
64
#	dh_installmanpages
58
	dh_installchangelogs
65
	dh_installchangelogs
59
	dh_link
66
	dh_link
60
	dh_strip
67
	dh_strip
61
	dh_compress
68
	dh_compress
62
	dh_fixperms
69
	dh_fixperms
63
	dh_installdeb
70
	dh_installdeb
64
	dh_shlibdeps
71
	dh_shlibdeps
65
	dh_gencontrol
72
	dh_gencontrol
66
	dh_md5sums
73
	dh_md5sums
67
	dh_builddeb
74
	dh_builddeb
68
75
69
binary: binary-indep binary-arch
76
binary: binary-indep binary-arch
70
.PHONY: build clean binary-indep binary-arch binary install
77
.PHONY: build clean binary-indep binary-arch binary install