Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 7 | Rev 14 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 7 Rev 10
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# debian/rules for freesweep
2
# debian/rules for freesweep
3
# modifications by Edward Betts <edward@debian.org>
3
# modifications by Edward Betts <edward@debian.org>
4
# Based on:
4
# Based on:
5
# Sample debian/rules that uses debhelper.
5
# Sample debian/rules that uses debhelper.
6
# GNU copyright 1997 to 1999 by Joey Hess.
6
# GNU copyright 1997 to 1999 by Joey Hess.
7
7
8
# Uncomment this to turn on verbose mode.
8
# Uncomment this to turn on verbose mode.
9
#export DH_VERBOSE=1
9
#export DH_VERBOSE=1
10
10
11
# This has to be exported to make some magic below work.
11
# This has to be exported to make some magic below work.
12
export DH_OPTIONS
12
export DH_OPTIONS
13
13
14
build: build-stamp
14
build: build-stamp
15
build-stamp:
15
build-stamp:
16
	dh_testdir
16
	dh_testdir
17
17
18
	xmkmf
18
	xmkmf
19
	#$(MAKE) x2vnc
19
	#$(MAKE) x2vnc
20
	$(MAKE)
20
	$(MAKE)
21
21
22
	touch build-stamp
22
	touch build-stamp
23
23
24
clean:
24
clean:
25
	dh_testdir
25
	dh_testdir
26
	dh_testroot
26
	dh_testroot
27
	rm -f build-stamp
27
	rm -f build-stamp
28
28
29
	[ ! -f Makefile ] || $(MAKE) clean
29
	[ ! -f Makefile ] || $(MAKE) distclean
30
30
31
	dh_clean Makefile
31
	dh_clean
32
32
33
install: build
33
install: build
34
	dh_testdir
34
	dh_testdir
35
	dh_testroot
35
	dh_testroot
36
	dh_clean -k
36
	dh_clean -k
37
37
38
	$(MAKE) DESTDIR=`pwd`/debian/x2vnc install
38
	$(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc MANSUFFIX=1 install
39
	mv debian/x2vnc/usr/share/man/man1/x2vnc.1x \
-
 
40
	   debian/x2vnc/usr/share/man/man1/x2vnc.1
-
 
41
39
42
# Build architecture-independent files here.
40
# Build architecture-independent files here.
43
binary-indep: build install
41
binary-indep:
44
# We have nothing to do by default.
42
# We have nothing to do by default.
45
43
46
# Build architecture-dependent files here.
44
# Build architecture-dependent files here.
47
binary-arch: build install
45
binary-arch: build install
48
	dh_testdir
46
	dh_testdir
49
	dh_testroot
47
	dh_testroot
50
	dh_installdocs
48
	dh_installdocs
51
	dh_installexamples
49
	dh_installexamples
52
	dh_installmenu
50
	dh_installmenu
53
#	dh_installmanpages
51
#	dh_installmanpages
54
	dh_installchangelogs
52
	dh_installchangelogs
55
	dh_link
53
	dh_link
56
	dh_strip
54
	dh_strip
57
	dh_compress
55
	dh_compress
58
	dh_fixperms
56
	dh_fixperms
59
	dh_installdeb
57
	dh_installdeb
60
	dh_shlibdeps
58
	dh_shlibdeps
61
	dh_gencontrol
59
	dh_gencontrol
62
	dh_md5sums
60
	dh_md5sums
63
	dh_builddeb
61
	dh_builddeb
64
62
65
binary: binary-indep binary-arch
63
binary: binary-indep binary-arch
66
.PHONY: build clean binary-indep binary-arch binary install
64
.PHONY: build clean binary-indep binary-arch binary install