Rev 27 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 27 | Rev 30 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # debian/rules for freesweep |
2 | # debian/rules for freesweep |
3 | # modifications by Edward Betts <edward@debian.org> |
3 | # modifications by Edward Betts <edward@debian.org> |
4 | # Based on: |
4 | # Based on: |
5 | # Sample debian/rules that uses debhelper. |
5 | # Sample debian/rules that uses debhelper. |
6 | # GNU copyright 1997 to 1999 by Joey Hess. |
6 | # GNU copyright 1997 to 1999 by Joey Hess. |
7 | 7 | ||
8 | # Uncomment this to turn on verbose mode. |
8 | # Uncomment this to turn on verbose mode. |
9 | #export DH_VERBOSE=1 |
9 | #export DH_VERBOSE=1 |
10 | 10 | ||
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | 13 | ||
14 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
14 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
15 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
15 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
16 | else |
16 | else |
17 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
17 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
18 | endif |
18 | endif |
19 | 19 | ||
20 | config-stamp: configure |
20 | config-stamp: configure |
21 | dh_testdir |
21 | dh_testdir |
22 | ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \ |
22 | ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \ |
23 | --prefix=/usr \ |
23 | --prefix=/usr \ |
24 | --mandir=\$${prefix}/share/man \ |
24 | --mandir=\$${prefix}/share/man \ |
25 | $(shell dpkg-buildflags --export=configure) |
25 | $(shell dpkg-buildflags --export=configure) |
26 | touch config-stamp |
26 | touch config-stamp |
27 | 27 | ||
28 | build: build-arch |
28 | build: build-arch |
29 | build-indep: |
29 | build-indep: |
30 | build-arch: build-stamp |
30 | build-arch: build-stamp |
31 | build-stamp: config-stamp |
31 | build-stamp: config-stamp |
32 | dh_testdir |
32 | dh_testdir |
33 | 33 | ||
34 | $(MAKE) |
34 | $(MAKE) |
35 | 35 | ||
36 | touch build-stamp |
36 | touch build-stamp |
37 | 37 | ||
38 | clean: |
38 | clean: |
39 | dh_testdir |
39 | dh_testdir |
40 | dh_testroot |
40 | dh_testroot |
41 | rm -f build-stamp |
- | |
42 | 41 | ||
43 | [ ! -f Makefile ] || $(MAKE) clean |
42 | [ ! -f Makefile ] || $(MAKE) clean |
44 | 43 | ||
45 | dh_clean config-stamp Makefile config.status config.log config.cache |
44 | dh_clean Makefile config.status config.log config.cache |
46 | 45 | ||
47 | install: build |
46 | install: build |
48 | dh_testdir |
47 | dh_testdir |
49 | dh_testroot |
48 | dh_testroot |
50 | dh_prep |
49 | dh_prep |
51 | 50 | ||
52 | install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share |
51 | install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share |
53 | $(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install |
52 | $(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install |
54 | 53 | ||
55 | # Build architecture-independent files here. |
54 | # Build architecture-independent files here. |
56 | binary-indep: |
55 | binary-indep: |
57 | # We have nothing to do by default. |
56 | # We have nothing to do by default. |
58 | 57 | ||
59 | # Build architecture-dependent files here. |
58 | # Build architecture-dependent files here. |
60 | binary-arch: build install |
59 | binary-arch: build install |
61 | dh_testdir |
60 | dh_testdir |
62 | dh_testroot |
61 | dh_testroot |
63 | dh_installdocs |
62 | dh_installdocs |
64 | dh_installexamples |
63 | dh_installexamples |
65 | dh_installmenu |
64 | dh_installmenu |
66 | # dh_installmanpages |
65 | # dh_installmanpages |
67 | dh_installchangelogs |
66 | dh_installchangelogs |
68 | dh_link |
67 | dh_link |
69 | dh_strip |
68 | dh_strip |
70 | dh_compress |
69 | dh_compress |
71 | dh_fixperms |
70 | dh_fixperms |
72 | dh_installdeb |
71 | dh_installdeb |
73 | dh_shlibdeps |
72 | dh_shlibdeps |
74 | dh_gencontrol |
73 | dh_gencontrol |
75 | dh_md5sums |
74 | dh_md5sums |
76 | dh_builddeb |
75 | dh_builddeb |
77 | 76 | ||
78 | binary: binary-indep binary-arch |
77 | binary: binary-indep binary-arch |
79 | .PHONY: build-arch build-indep build clean binary-indep binary-arch binary install |
78 | .PHONY: build-arch build-indep build clean binary-indep binary-arch binary install |