Rev 10 | Rev 21 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
3 | magnus | 1 | #!/usr/bin/make -f |
2 | # debian/rules for freesweep |
||
3 | # modifications by Edward Betts <edward@debian.org> |
||
4 | # Based on: |
||
5 | # Sample debian/rules that uses debhelper. |
||
6 | # GNU copyright 1997 to 1999 by Joey Hess. |
||
7 | |||
8 | # Uncomment this to turn on verbose mode. |
||
9 | #export DH_VERBOSE=1 |
||
10 | |||
11 | # This has to be exported to make some magic below work. |
||
12 | export DH_OPTIONS |
||
13 | |||
14 | magnus | 14 | config-stamp: configure |
15 | dh_testdir |
||
16 | ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \ |
||
17 | --prefix=/usr \ |
||
18 | --mandir=\$${prefix}/share/man |
||
19 | touch config-stamp |
||
20 | |||
3 | magnus | 21 | build: build-stamp |
14 | magnus | 22 | build-stamp: config-stamp |
3 | magnus | 23 | dh_testdir |
24 | |||
25 | $(MAKE) |
||
26 | |||
27 | touch build-stamp |
||
28 | |||
29 | clean: |
||
30 | dh_testdir |
||
31 | dh_testroot |
||
32 | rm -f build-stamp |
||
33 | |||
14 | magnus | 34 | [ ! -f Makefile ] || $(MAKE) clean |
3 | magnus | 35 | |
14 | magnus | 36 | dh_clean config-stamp Makefile config.status config.log config.cache |
3 | magnus | 37 | |
38 | install: build |
||
39 | dh_testdir |
||
40 | dh_testroot |
||
41 | dh_clean -k |
||
42 | |||
14 | magnus | 43 | install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share |
44 | $(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install |
||
3 | magnus | 45 | |
46 | # Build architecture-independent files here. |
||
10 | magnus | 47 | binary-indep: |
3 | magnus | 48 | # We have nothing to do by default. |
49 | |||
50 | # Build architecture-dependent files here. |
||
51 | binary-arch: build install |
||
52 | dh_testdir |
||
53 | dh_testroot |
||
54 | dh_installdocs |
||
55 | dh_installexamples |
||
56 | dh_installmenu |
||
57 | # dh_installmanpages |
||
58 | dh_installchangelogs |
||
59 | dh_link |
||
60 | dh_strip |
||
61 | dh_compress |
||
62 | dh_fixperms |
||
63 | dh_installdeb |
||
64 | dh_shlibdeps |
||
65 | dh_gencontrol |
||
66 | dh_md5sums |
||
67 | dh_builddeb |
||
68 | |||
69 | binary: binary-indep binary-arch |
||
70 | .PHONY: build clean binary-indep binary-arch binary install |