Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 7 | Rev 14 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# debian/rules for freesweep
3
# modifications by Edward Betts <edward@debian.org>
4
# Based on:
5
# Sample debian/rules that uses debhelper.
6
# GNU copyright 1997 to 1999 by Joey Hess.
7
 
8
# Uncomment this to turn on verbose mode.
9
#export DH_VERBOSE=1
10
 
11
# This has to be exported to make some magic below work.
12
export DH_OPTIONS
13
 
14
build: build-stamp
15
build-stamp:
16
	dh_testdir
17
 
18
	xmkmf
19
	#$(MAKE) x2vnc
20
	$(MAKE)
21
 
22
	touch build-stamp
23
 
24
clean:
25
	dh_testdir
26
	dh_testroot
27
	rm -f build-stamp
28
 
10 magnus 29
	[ ! -f Makefile ] || $(MAKE) distclean
3 magnus 30
 
10 magnus 31
	dh_clean
3 magnus 32
 
33
install: build
34
	dh_testdir
35
	dh_testroot
36
	dh_clean -k
37
 
10 magnus 38
	$(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc MANSUFFIX=1 install
3 magnus 39
 
40
# Build architecture-independent files here.
10 magnus 41
binary-indep:
3 magnus 42
# We have nothing to do by default.
43
 
44
# Build architecture-dependent files here.
45
binary-arch: build install
46
	dh_testdir
47
	dh_testroot
48
	dh_installdocs
49
	dh_installexamples
50
	dh_installmenu
51
#	dh_installmanpages
52
	dh_installchangelogs
53
	dh_link
54
	dh_strip
55
	dh_compress
56
	dh_fixperms
57
	dh_installdeb
58
	dh_shlibdeps
59
	dh_gencontrol
60
	dh_md5sums
61
	dh_builddeb
62
 
63
binary: binary-indep binary-arch
64
.PHONY: build clean binary-indep binary-arch binary install