Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 7 | Go to most recent revision | Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# debian/rules for freesweep
3
# modifications by Edward Betts <edward@debian.org>
4
# Based on:
5
# Sample debian/rules that uses debhelper.
6
# GNU copyright 1997 to 1999 by Joey Hess.
7
 
8
# Uncomment this to turn on verbose mode.
9
#export DH_VERBOSE=1
10
 
11
# This has to be exported to make some magic below work.
12
export DH_OPTIONS
13
 
14
build: build-stamp
15
build-stamp:
16
	dh_testdir
17
 
18
	xmkmf
19
	#$(MAKE) x2vnc
20
	$(MAKE)
21
 
22
	touch build-stamp
23
 
24
clean:
25
	dh_testdir
26
	dh_testroot
27
	rm -f build-stamp
28
 
29
	[ ! -f Makefile ] || $(MAKE) clean
30
 
31
	dh_clean Makefile
32
 
33
install: build
34
	dh_testdir
35
	dh_testroot
36
	dh_clean -k
37
	dh_installdirs
38
 
39
	#install -o root -g root -m 755 x2vnc \
40
	#	`pwd`/debian/x2vnc/usr/X11R6/bin
41
	$(MAKE) DESTDIR=`pwd`/debian/x2vnc install
42
	#mkdir -p debian/x2vnc/usr/X11R6/bin
43
	#-mv debian/x2vnc/usr/X11R6/bin/* debian/x2vnc/usr/bin
44
	#mkdir -p debian/x2vnc/usr/share/man
45
	#-mv debian/x2vnc/usr/X11R6/man/* debian/x2vnc/usr/share/man
46
	-rmdir debian/x2vnc/usr/X11R6/bin
47
	#-rmdir debian/x2vnc/usr/X11R6/man
48
	-rmdir debian/x2vnc/usr/X11R6
49
	mv debian/x2vnc/usr/share/man/man1/x2vnc.1x \
50
	   debian/x2vnc/usr/share/man/man1/x2vnc.1
51
 
52
# Build architecture-independent files here.
53
binary-indep: build install
54
# We have nothing to do by default.
55
 
56
# Build architecture-dependent files here.
57
binary-arch: build install
58
	dh_testdir
59
	dh_testroot
60
#	dh_installdebconf
61
	dh_installdocs
62
	dh_installexamples
63
	dh_installmenu
64
#	dh_installemacsen
65
#	dh_installpam
66
#	dh_installmime
67
#	dh_installinit
68
#	dh_installcron
69
#	dh_installmanpages
70
#	dh_installinfo
71
#	dh_undocumented
72
	dh_installchangelogs
73
	dh_link
74
	dh_strip
75
	dh_compress
76
	dh_fixperms
77
#	dh_makeshlibs
78
	dh_installdeb
79
#	dh_perl
80
	dh_shlibdeps
81
	dh_gencontrol
82
	dh_md5sums
83
	dh_builddeb
84
 
85
binary: binary-indep binary-arch
86
.PHONY: build clean binary-indep binary-arch binary install