Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 27 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# debian/rules for freesweep
3
# modifications by Edward Betts <edward@debian.org>
4
# Based on:
5
# Sample debian/rules that uses debhelper.
6
# GNU copyright 1997 to 1999 by Joey Hess.
7
 
8
# Uncomment this to turn on verbose mode.
9
#export DH_VERBOSE=1
10
 
21 magnus 11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
3 magnus 13
 
21 magnus 14
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
15
  buildflags = --build=$(DEB_BUILD_GNU_TYPE)
16
else
17
  buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
18
endif
19
 
14 magnus 20
config-stamp: configure
21
	dh_testdir
22
	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
23
	        --prefix=/usr \
21 magnus 24
	        --mandir=\$${prefix}/share/man \
25
	        $(shell dpkg-buildflags --export=configure)
14 magnus 26
	touch config-stamp
27
 
22 magnus 28
build: build-arch
29
build-indep:
30
build-arch: build-stamp
14 magnus 31
build-stamp: config-stamp
3 magnus 32
	dh_testdir
33
 
34
	$(MAKE)
35
 
36
	touch build-stamp
37
 
38
clean:
39
	dh_testdir
40
	dh_testroot
41
 
14 magnus 42
	[ ! -f Makefile ] || $(MAKE) clean
3 magnus 43
 
30 magnus 44
	dh_clean Makefile config.status config.log config.cache
3 magnus 45
 
46
install: build
47
	dh_testdir
48
	dh_testroot
27 magnus 49
	dh_prep
3 magnus 50
 
14 magnus 51
	install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share
52
	$(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install
3 magnus 53
 
54
# Build architecture-independent files here.
10 magnus 55
binary-indep:
3 magnus 56
# We have nothing to do by default.
57
 
58
# Build architecture-dependent files here.
59
binary-arch: build install
60
	dh_testdir
61
	dh_testroot
62
	dh_installdocs
63
	dh_installexamples
64
	dh_installmenu
65
#	dh_installmanpages
66
	dh_installchangelogs
67
	dh_link
68
	dh_strip
69
	dh_compress
70
	dh_fixperms
71
	dh_installdeb
72
	dh_shlibdeps
73
	dh_gencontrol
74
	dh_md5sums
75
	dh_builddeb
76
 
77
binary: binary-indep binary-arch
22 magnus 78
.PHONY: build-arch build-indep build clean binary-indep binary-arch binary install