Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Rev 14 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# debian/rules for freesweep
3
# modifications by Edward Betts <edward@debian.org>
4
# Based on:
5
# Sample debian/rules that uses debhelper.
6
# GNU copyright 1997 to 1999 by Joey Hess.
7
 
8
# Uncomment this to turn on verbose mode.
9
#export DH_VERBOSE=1
10
 
11
# This has to be exported to make some magic below work.
12
export DH_OPTIONS
13
 
14
build: build-stamp
15
build-stamp:
16
	dh_testdir
17
 
18
	xmkmf
19
	#$(MAKE) x2vnc
20
	$(MAKE)
21
 
22
	touch build-stamp
23
 
24
clean:
25
	dh_testdir
26
	dh_testroot
27
	rm -f build-stamp
28
 
29
	[ ! -f Makefile ] || $(MAKE) clean
30
 
31
	dh_clean Makefile
32
 
33
install: build
34
	dh_testdir
35
	dh_testroot
36
	dh_clean -k
37
 
38
	$(MAKE) DESTDIR=`pwd`/debian/x2vnc install
39
	mv debian/x2vnc/usr/share/man/man1/x2vnc.1x \
40
	   debian/x2vnc/usr/share/man/man1/x2vnc.1
41
 
42
# Build architecture-independent files here.
43
binary-indep: build install
44
# We have nothing to do by default.
45
 
46
# Build architecture-dependent files here.
47
binary-arch: build install
48
	dh_testdir
49
	dh_testroot
50
	dh_installdocs
51
	dh_installexamples
52
	dh_installmenu
53
#	dh_installmanpages
54
	dh_installchangelogs
55
	dh_link
56
	dh_strip
57
	dh_compress
58
	dh_fixperms
59
	dh_installdeb
60
	dh_shlibdeps
61
	dh_gencontrol
62
	dh_md5sums
63
	dh_builddeb
64
 
65
binary: binary-indep binary-arch
66
.PHONY: build clean binary-indep binary-arch binary install