Rev 7 | Rev 14 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 7 | Rev 10 | ||
---|---|---|---|
Line 24... | Line 24... | ||
24 | clean: |
24 | clean: |
25 | dh_testdir |
25 | dh_testdir |
26 | dh_testroot |
26 | dh_testroot |
27 | rm -f build-stamp |
27 | rm -f build-stamp |
28 | 28 | ||
29 | [ ! -f Makefile ] || $(MAKE) clean |
29 | [ ! -f Makefile ] || $(MAKE) distclean |
30 | 30 | ||
31 | dh_clean Makefile |
31 | dh_clean |
32 | 32 | ||
33 | install: build |
33 | install: build |
34 | dh_testdir |
34 | dh_testdir |
35 | dh_testroot |
35 | dh_testroot |
36 | dh_clean -k |
36 | dh_clean -k |
37 | 37 | ||
38 | $(MAKE) DESTDIR=`pwd`/debian/x2vnc install |
38 | $(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc MANSUFFIX=1 install |
39 | mv debian/x2vnc/usr/share/man/man1/x2vnc.1x \ |
- | |
40 | debian/x2vnc/usr/share/man/man1/x2vnc.1 |
- | |
41 | 39 | ||
42 | # Build architecture-independent files here. |
40 | # Build architecture-independent files here. |
43 | binary-indep: build install |
41 | binary-indep: |
44 | # We have nothing to do by default. |
42 | # We have nothing to do by default. |
45 | 43 | ||
46 | # Build architecture-dependent files here. |
44 | # Build architecture-dependent files here. |
47 | binary-arch: build install |
45 | binary-arch: build install |
48 | dh_testdir |
46 | dh_testdir |