Rev 10 | Rev 21 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 10 | Rev 14 | ||
---|---|---|---|
Line 9... | Line 9... | ||
9 | #export DH_VERBOSE=1 |
9 | #export DH_VERBOSE=1 |
10 | 10 | ||
11 | # This has to be exported to make some magic below work. |
11 | # This has to be exported to make some magic below work. |
12 | export DH_OPTIONS |
12 | export DH_OPTIONS |
13 | 13 | ||
- | 14 | config-stamp: configure |
|
- | 15 | dh_testdir |
|
- | 16 | ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \ |
|
- | 17 | --prefix=/usr \ |
|
- | 18 | --mandir=\$${prefix}/share/man |
|
- | 19 | touch config-stamp |
|
- | 20 | ||
14 | build: build-stamp |
21 | build: build-stamp |
15 | build-stamp: |
22 | build-stamp: config-stamp |
16 | dh_testdir |
23 | dh_testdir |
17 | 24 | ||
18 | xmkmf |
- | |
19 | #$(MAKE) x2vnc |
- | |
20 | $(MAKE) |
25 | $(MAKE) |
21 | 26 | ||
22 | touch build-stamp |
27 | touch build-stamp |
23 | 28 | ||
24 | clean: |
29 | clean: |
25 | dh_testdir |
30 | dh_testdir |
26 | dh_testroot |
31 | dh_testroot |
27 | rm -f build-stamp |
32 | rm -f build-stamp |
28 | 33 | ||
29 | [ ! -f Makefile ] || $(MAKE) distclean |
34 | [ ! -f Makefile ] || $(MAKE) clean |
30 | 35 | ||
31 | dh_clean |
36 | dh_clean config-stamp Makefile config.status config.log config.cache |
32 | 37 | ||
33 | install: build |
38 | install: build |
34 | dh_testdir |
39 | dh_testdir |
35 | dh_testroot |
40 | dh_testroot |
36 | dh_clean -k |
41 | dh_clean -k |
37 | 42 | ||
- | 43 | install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share |
|
38 | $(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc MANSUFFIX=1 install |
44 | $(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install |
39 | 45 | ||
40 | # Build architecture-independent files here. |
46 | # Build architecture-independent files here. |
41 | binary-indep: |
47 | binary-indep: |
42 | # We have nothing to do by default. |
48 | # We have nothing to do by default. |
43 | 49 |