Rev 3 | Rev 10 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 3 | Rev 7 | ||
---|---|---|---|
Line 32... | Line 32... | ||
32 | 32 | ||
33 | install: build |
33 | install: build |
34 | dh_testdir |
34 | dh_testdir |
35 | dh_testroot |
35 | dh_testroot |
36 | dh_clean -k |
36 | dh_clean -k |
37 | dh_installdirs |
- | |
38 | 37 | ||
39 | #install -o root -g root -m 755 x2vnc \ |
- | |
40 | # `pwd`/debian/x2vnc/usr/X11R6/bin |
- | |
41 | $(MAKE) DESTDIR=`pwd`/debian/x2vnc install |
38 | $(MAKE) DESTDIR=`pwd`/debian/x2vnc install |
42 | #mkdir -p debian/x2vnc/usr/X11R6/bin |
- | |
43 | #-mv debian/x2vnc/usr/X11R6/bin/* debian/x2vnc/usr/bin |
- | |
44 | #mkdir -p debian/x2vnc/usr/share/man |
- | |
45 | #-mv debian/x2vnc/usr/X11R6/man/* debian/x2vnc/usr/share/man |
- | |
46 | -rmdir debian/x2vnc/usr/X11R6/bin |
- | |
47 | #-rmdir debian/x2vnc/usr/X11R6/man |
- | |
48 | -rmdir debian/x2vnc/usr/X11R6 |
- | |
49 | mv debian/x2vnc/usr/share/man/man1/x2vnc.1x \ |
39 | mv debian/x2vnc/usr/share/man/man1/x2vnc.1x \ |
50 | debian/x2vnc/usr/share/man/man1/x2vnc.1 |
40 | debian/x2vnc/usr/share/man/man1/x2vnc.1 |
51 | 41 | ||
52 | # Build architecture-independent files here. |
42 | # Build architecture-independent files here. |
53 | binary-indep: build install |
43 | binary-indep: build install |
Line 55... | Line 45... | ||
55 | 45 | ||
56 | # Build architecture-dependent files here. |
46 | # Build architecture-dependent files here. |
57 | binary-arch: build install |
47 | binary-arch: build install |
58 | dh_testdir |
48 | dh_testdir |
59 | dh_testroot |
49 | dh_testroot |
60 | # dh_installdebconf |
- | |
61 | dh_installdocs |
50 | dh_installdocs |
62 | dh_installexamples |
51 | dh_installexamples |
63 | dh_installmenu |
52 | dh_installmenu |
64 | # dh_installemacsen |
- | |
65 | # dh_installpam |
- | |
66 | # dh_installmime |
- | |
67 | # dh_installinit |
- | |
68 | # dh_installcron |
- | |
69 | # dh_installmanpages |
53 | # dh_installmanpages |
70 | # dh_installinfo |
- | |
71 | # dh_undocumented |
- | |
72 | dh_installchangelogs |
54 | dh_installchangelogs |
73 | dh_link |
55 | dh_link |
74 | dh_strip |
56 | dh_strip |
75 | dh_compress |
57 | dh_compress |
76 | dh_fixperms |
58 | dh_fixperms |
77 | # dh_makeshlibs |
- | |
78 | dh_installdeb |
59 | dh_installdeb |
79 | # dh_perl |
- | |
80 | dh_shlibdeps |
60 | dh_shlibdeps |
81 | dh_gencontrol |
61 | dh_gencontrol |
82 | dh_md5sums |
62 | dh_md5sums |
83 | dh_builddeb |
63 | dh_builddeb |
84 | 64 |