Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 10 | Rev 22 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 10 Rev 14
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# debian/rules for freesweep
2
# debian/rules for freesweep
3
# modifications by Edward Betts <edward@debian.org>
3
# modifications by Edward Betts <edward@debian.org>
4
# Based on:
4
# Based on:
5
# Sample debian/rules that uses debhelper.
5
# Sample debian/rules that uses debhelper.
6
# GNU copyright 1997 to 1999 by Joey Hess.
6
# GNU copyright 1997 to 1999 by Joey Hess.
7
7
8
# Uncomment this to turn on verbose mode.
8
# Uncomment this to turn on verbose mode.
9
#export DH_VERBOSE=1
9
#export DH_VERBOSE=1
10
10
11
# This has to be exported to make some magic below work.
11
# This has to be exported to make some magic below work.
12
export DH_OPTIONS
12
export DH_OPTIONS
13
13
-
 
14
config-stamp: configure
-
 
15
	dh_testdir
-
 
16
	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
-
 
17
	        --prefix=/usr \
-
 
18
	        --mandir=\$${prefix}/share/man
-
 
19
	touch config-stamp
-
 
20
14
build: build-stamp
21
build: build-stamp
15
build-stamp:
22
build-stamp: config-stamp
16
	dh_testdir
23
	dh_testdir
17
24
18
	xmkmf
-
 
19
	#$(MAKE) x2vnc
-
 
20
	$(MAKE)
25
	$(MAKE)
21
26
22
	touch build-stamp
27
	touch build-stamp
23
28
24
clean:
29
clean:
25
	dh_testdir
30
	dh_testdir
26
	dh_testroot
31
	dh_testroot
27
	rm -f build-stamp
32
	rm -f build-stamp
28
33
29
	[ ! -f Makefile ] || $(MAKE) distclean
34
	[ ! -f Makefile ] || $(MAKE) clean
30
35
31
	dh_clean
36
	dh_clean config-stamp Makefile config.status config.log config.cache
32
37
33
install: build
38
install: build
34
	dh_testdir
39
	dh_testdir
35
	dh_testroot
40
	dh_testroot
36
	dh_clean -k
41
	dh_clean -k
37
42
-
 
43
	install -m 755 -d $(CURDIR)/debian/x2vnc/usr/share
38
	$(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc MANSUFFIX=1 install
44
	$(MAKE) DESTDIR=$(CURDIR)/debian/x2vnc install
39
45
40
# Build architecture-independent files here.
46
# Build architecture-independent files here.
41
binary-indep:
47
binary-indep:
42
# We have nothing to do by default.
48
# We have nothing to do by default.
43
49
44
# Build architecture-dependent files here.
50
# Build architecture-dependent files here.
45
binary-arch: build install
51
binary-arch: build install
46
	dh_testdir
52
	dh_testdir
47
	dh_testroot
53
	dh_testroot
48
	dh_installdocs
54
	dh_installdocs
49
	dh_installexamples
55
	dh_installexamples
50
	dh_installmenu
56
	dh_installmenu
51
#	dh_installmanpages
57
#	dh_installmanpages
52
	dh_installchangelogs
58
	dh_installchangelogs
53
	dh_link
59
	dh_link
54
	dh_strip
60
	dh_strip
55
	dh_compress
61
	dh_compress
56
	dh_fixperms
62
	dh_fixperms
57
	dh_installdeb
63
	dh_installdeb
58
	dh_shlibdeps
64
	dh_shlibdeps
59
	dh_gencontrol
65
	dh_gencontrol
60
	dh_md5sums
66
	dh_md5sums
61
	dh_builddeb
67
	dh_builddeb
62
68
63
binary: binary-indep binary-arch
69
binary: binary-indep binary-arch
64
.PHONY: build clean binary-indep binary-arch binary install
70
.PHONY: build clean binary-indep binary-arch binary install