Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 14 | Rev 22 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 14 Rev 21
Line 6... Line 6...
6
# GNU copyright 1997 to 1999 by Joey Hess.
6
# GNU copyright 1997 to 1999 by Joey Hess.
7
7
8
# Uncomment this to turn on verbose mode.
8
# Uncomment this to turn on verbose mode.
9
#export DH_VERBOSE=1
9
#export DH_VERBOSE=1
10
10
11
# This has to be exported to make some magic below work.
11
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-
 
12
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
 
13
12
export DH_OPTIONS
14
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
-
 
15
  buildflags = --build=$(DEB_BUILD_GNU_TYPE)
-
 
16
else
-
 
17
  buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
-
 
18
endif
13
19
14
config-stamp: configure
20
config-stamp: configure
15
	dh_testdir
21
	dh_testdir
16
	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
22
	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
17
	        --prefix=/usr \
23
	        --prefix=/usr \
18
	        --mandir=\$${prefix}/share/man
24
	        --mandir=\$${prefix}/share/man \
-
 
25
	        $(shell dpkg-buildflags --export=configure)
19
	touch config-stamp
26
	touch config-stamp
20
27
21
build: build-stamp
28
build: build-stamp
22
build-stamp: config-stamp
29
build-stamp: config-stamp
23
	dh_testdir
30
	dh_testdir