Rev 7 | Go to most recent revision | Blame | Compare with Previous | Last modification | View Log | RSS feed
#!/usr/bin/make -f
# debian/rules for freesweep
# modifications by Edward Betts <edward@debian.org>
# Based on:
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
# This has to be exported to make some magic below work.
export DH_OPTIONS
build: build-stamp
build-stamp:
dh_testdir
xmkmf
#$(MAKE) x2vnc
$(MAKE)
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
[ ! -f Makefile ] || $(MAKE) clean
dh_clean Makefile
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
#install -o root -g root -m 755 x2vnc \
# `pwd`/debian/x2vnc/usr/X11R6/bin
$(MAKE) DESTDIR=`pwd`/debian/x2vnc install
#mkdir -p debian/x2vnc/usr/X11R6/bin
#-mv debian/x2vnc/usr/X11R6/bin/* debian/x2vnc/usr/bin
#mkdir -p debian/x2vnc/usr/share/man
#-mv debian/x2vnc/usr/X11R6/man/* debian/x2vnc/usr/share/man
-rmdir debian/x2vnc/usr/X11R6/bin
#-rmdir debian/x2vnc/usr/X11R6/man
-rmdir debian/x2vnc/usr/X11R6
mv debian/x2vnc/usr/share/man/man1/x2vnc.1x \
debian/x2vnc/usr/share/man/man1/x2vnc.1
# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
binary-arch: build install
dh_testdir
dh_testroot
# dh_installdebconf
dh_installdocs
dh_installexamples
dh_installmenu
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_installinit
# dh_installcron
# dh_installmanpages
# dh_installinfo
# dh_undocumented
dh_installchangelogs
dh_link
dh_strip
dh_compress
dh_fixperms
# dh_makeshlibs
dh_installdeb
# dh_perl
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install