Subversion Repositories x2vnc

Compare Revisions

Ignore whitespace Rev 20 → Rev 21

/trunk/debian/rules
8,14 → 8,21
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
 
# This has to be exported to make some magic below work.
export DH_OPTIONS
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
buildflags = --build=$(DEB_BUILD_GNU_TYPE)
else
buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
endif
 
config-stamp: configure
dh_testdir
./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/usr \
--mandir=\$${prefix}/share/man
--mandir=\$${prefix}/share/man \
$(shell dpkg-buildflags --export=configure)
touch config-stamp
 
build: build-stamp