Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 5 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
5 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## 30_extra_fields.dpatch by Tom Kistner <tom@duncanthrax.net>
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Add Domain and IdentityDomain fields to struct DKIMVerifyDetails.
6
 
7
@DPATCH@
8
 
9
diff -w -xdebian -ur libdkim-1.0.14/src/dkim.h libdkim-1.0.15-tk/src/dkim.h
10
--- libdkim-1.0.14/src/dkim.h	2007-05-03 17:53:09.000000000 +0200
11
+++ libdkim-1.0.15-tk/src/dkim.h	2007-09-28 13:08:04.000000000 +0200
28 magnus 12
@@ -138,6 +138,8 @@
5 magnus 13
 	char *szSignature;
14
 	char *DNS;
28 magnus 15
	char *szCanonicalizedData;
5 magnus 16
+       char *Domain;
17
+       char *IdentityDomain;
18
 	int nResult;
19
 } DKIMVerifyDetails;
20
 
21
diff -w -xdebian -ur libdkim-1.0.14/src/dkimverify.cpp libdkim-1.0.15-tk/src/dkimverify.cpp
22
--- libdkim-1.0.14/src/dkimverify.cpp	2007-04-24 11:01:58.000000000 +0200
23
+++ libdkim-1.0.15-tk/src/dkimverify.cpp	2007-09-28 08:05:01.000000000 +0200
28 magnus 24
@@ -1508,6 +1508,10 @@
5 magnus 25
 		d.szSignature = (char*)i->Header.c_str();
26
 		d.nResult = i->Status;
28 magnus 27
		d.szCanonicalizedData = (char*)i->CanonicalizedData.c_str();
5 magnus 28
+
29
+		d.Domain = (char*)i->Domain.c_str();
30
+		d.IdentityDomain = i->IdentityDomain.empty()?(char*)i->IdentityDomain.c_str():(char*)i->Domain.c_str();
31
+
32
 		Details.push_back(d);
33
 	}
34