Subversion Repositories libdkim

Compare Revisions

Ignore whitespace Rev 27 → Rev 28

/branches/exp-tk/debian/patches/30_extra_fields.dpatch
9,10 → 9,10
diff -w -xdebian -ur libdkim-1.0.14/src/dkim.h libdkim-1.0.15-tk/src/dkim.h
--- libdkim-1.0.14/src/dkim.h 2007-05-03 17:53:09.000000000 +0200
+++ libdkim-1.0.15-tk/src/dkim.h 2007-09-28 13:08:04.000000000 +0200
@@ -137,6 +137,8 @@
{
@@ -138,6 +138,8 @@
char *szSignature;
char *DNS;
char *szCanonicalizedData;
+ char *Domain;
+ char *IdentityDomain;
int nResult;
21,10 → 21,10
diff -w -xdebian -ur libdkim-1.0.14/src/dkimverify.cpp libdkim-1.0.15-tk/src/dkimverify.cpp
--- libdkim-1.0.14/src/dkimverify.cpp 2007-04-24 11:01:58.000000000 +0200
+++ libdkim-1.0.15-tk/src/dkimverify.cpp 2007-09-28 08:05:01.000000000 +0200
@@ -1428,6 +1386,10 @@
DKIMVerifyDetails d;
@@ -1508,6 +1508,10 @@
d.szSignature = (char*)i->Header.c_str();
d.nResult = i->Status;
d.szCanonicalizedData = (char*)i->CanonicalizedData.c_str();
+
+ d.Domain = (char*)i->Domain.c_str();
+ d.IdentityDomain = i->IdentityDomain.empty()?(char*)i->IdentityDomain.c_str():(char*)i->Domain.c_str();