Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 15 | Blame | Compare with Previous | Last modification | View Log | RSS feed

#!/bin/sh
## 35_untabify_help.dpatch by Magnus Holmgren <magnus@kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Tidy up --help messages by converting tabs to four spaces ("    ").

FILES_TO_PROCESS="src/spfquery/spfquery.c
                  src/spftest/spftest.c
                  src/spf_example/spf_example.c"

dpatch_patch() {
    # Change line endings to LF in files with CRLF
    perl -pi -e 's/("[^"]*?)\t/$1    / and redo;' $FILES_TO_PROCESS
}

dpatch_unpatch() {
    # Change line endings back to CRLF in files that had it in the tarball
    # Unfortunately there are exceptions ... have to watch out for changes
    # in future upstream versions (or simply make backups instead).
    perl -pi -e 's/("[^"]*?)    /$1\t/ and redo;' $FILES_TO_PROCESS
}

DPATCH_LIB_NO_DEFAULT=1

. /usr/share/dpatch/dpatch.lib.sh