Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Blame | Last modification | View Log | RSS feed

Description: Escape hyphens that should be minus signs in man pages.

--- a/doc/tar_append_file.3
+++ b/doc/tar_append_file.3
@@ -31,7 +31,7 @@ The \fBtar_append_eof\fP() function writ
 all zeros) to the tar file associated with \fIt\fP.
 .SH RETURN VALUES
 On successful completion, these functions will return 0.  On failure,
-they will return -1 and set \fIerrno\fP to an appropriate value.
+they will return \-1 and set \fIerrno\fP to an appropriate value.
 .SH ERRORS
 The \fBtar_append_*\fP() functions will fail if:
 .IP \fBEINVAL\fP
--- a/doc/tar_extract_all.3
+++ b/doc/tar_extract_all.3
@@ -30,7 +30,7 @@ are modified by replacing \fIrealdir\fP
 files will be extracted into \fIsavedir\fP.
 .SH RETURN VALUES
 On successful completion, these functions will return 0.  On failure,
-they will return -1 and set \fIerrno\fP to an appropriate value.
+they will return \-1 and set \fIerrno\fP to an appropriate value.
 .SH ERRORS
 These functions will fail under the same conditions that the
 \fBtar_skip_regfile\fP(), \fBtar_extract_regfile\fP(), \fBopendir\fP(),
--- a/doc/tar_extract_file.3
+++ b/doc/tar_extract_file.3
@@ -48,7 +48,7 @@ other \fBtar_extract_*\fP() functions di
 \fBtar_set_file_perms\fP() manually if this behavior is desired.
 .SH RETURN VALUES
 On successful completion, the functions documented here will
-return 0.  On failure, they will return -1 and set \fIerrno\fP to an
+return 0.  On failure, they will return \-1 and set \fIerrno\fP to an
 appropriate value.
 
 The \fBtar_extract_dir\fP() function will return 1 if the directory
--- a/doc/th_print_long_ls.3
+++ b/doc/th_print_long_ls.3
@@ -12,7 +12,7 @@ This man page documents version 1.2 of \
 .SH DESCRIPTION
 The \fBth_print_long_ls\fP() function prints a line to \fIstdout\fP which
 describes the file pointed to by the current file header associated with
-the \fITAR\fP handle \fIt\fP.  The output is similar to that of "ls -l".
+the \fITAR\fP handle \fIt\fP.  The output is similar to that of "ls \-l".
 
 The \fBth_print\fP() function prints the value of each field of the
 current file header associated with the \fITAR\fP handle \fIt\fP to
--- a/doc/th_read.3
+++ b/doc/th_read.3
@@ -20,7 +20,7 @@ tar header associated with \fIt\fP to th
 with \fIt\fP.
 .SH RETURN VALUE
 On successful completion, \fBth_read\fP() and \fBth_write\fP() will
-return 0.  On failure, they will return -1 and set \fIerrno\fP to an
+return 0.  On failure, they will return \-1 and set \fIerrno\fP to an
 appropriate value.
 
 On \fIEOF\fP, \fBth_read\fP() will return 1.
--- a/doc/tar_open.3
+++ b/doc/tar_open.3
@@ -79,7 +79,7 @@ with the \fITAR\fP handle \fIt\fP and fr
 memory.
 .SH RETURN VALUE
 The \fBtar_open\fP(), \fBtar_fdopen\fP(), and \fBtar_close\fP() functions
-return 0 on success.  On failure, they return -1 and set \fIerrno\fP.
+return 0 on success.  On failure, they return \-1 and set \fIerrno\fP.
 
 The \fBtar_fd\fP() function returns the file descriptor associated with
 the \fITAR\fP handle \fIt\fP.
--- a/listhash/hash_new.3.in
+++ b/listhash/hash_new.3.in
@@ -39,7 +39,7 @@ used to iterate through the hash.  The \
 has two fields: \fIbucket\fP, which indicates the current bucket in the
 hash, and \fInode\fP, which is a pointer to the current node in the current
 bucket.  To start at the beginning or end of the hash, the caller should
-initialize \fIhp.bucket\fP to -1 and \fIhp.node\fP to \fINULL\fP.
+initialize \fIhp.bucket\fP to \-1 and \fIhp.node\fP to \fINULL\fP.
 
 The \fB@LISTHASH_PREFIX@_hash_search\fP() function searches iteratively through the
 hash \fIh\fP until it finds a node whose contents match \fIdata\fP using
@@ -65,10 +65,10 @@ return 1 when valid data is returned, an
 The \fB@LISTHASH_PREFIX@_hash_getkey\fP() and \fB@LISTHASH_PREFIX@_hash_search\fP() functions
 return 1 when a match is found, or 0 otherwise.
 
-The \fB@LISTHASH_PREFIX@_hash_add\fP() function returns 0 on success, or -1 on
+The \fB@LISTHASH_PREFIX@_hash_add\fP() function returns 0 on success, or \-1 on
 error (and sets \fIerrno\fP).
 
-The \fB@LISTHASH_PREFIX@_hash_del\fP() function returns 0 on success, or -1 on
+The \fB@LISTHASH_PREFIX@_hash_del\fP() function returns 0 on success, or \-1 on
 error (and sets \fIerrno\fP).
 .SH SEE ALSO
 .BR @LISTHASH_PREFIX@_list_new (3)
--- a/listhash/list_new.3.in
+++ b/listhash/list_new.3.in
@@ -81,6 +81,6 @@ The \fB@LISTHASH_PREFIX@_list_next\fP(),
 returned, or 0 otherwise.
 
 The \fB@LISTHASH_PREFIX@_list_add\fP() and \fB@LISTHASH_PREFIX@_list_add_str\fP() functions
-return 0 on success, or -1 on error.
+return 0 on success, or \-1 on error.
 .SH SEE ALSO
 .BR @LISTHASH_PREFIX@_hash_new (3)