Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Blame | Last modification | View Log | RSS feed

--- a/src/sftp/rl.c
+++ b/src/sftp/rl.c
@@ -116,7 +116,7 @@ void lsftp_rl_init()
   rl_basic_word_break_characters =" \n\t"; /* Only whitespace break words */
 
   RL_CHAR_IS_QUOTED = char_quoted;
-  rl_attempted_completion_function = (CPPFunction *)lsftp_rl_completion;
+  rl_attempted_completion_function = (rl_completion_func_t *)lsftp_rl_completion;
 
 
   interactive = 1; /* Set the interactive flag in the main program */