Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Blame | Compare with Previous | Last modification | View Log | RSS feed

#! /bin/sh /usr/share/dpatch/dpatch-run
## 05_install.pike.dpatch by  <magnus@proffe.kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Allow include_prefix to be separately overridden in install.pike

@DPATCH@
diff -urNad pike7.8-7.8.116~/src/Makefile.in pike7.8-7.8.116/src/Makefile.in
--- pike7.8-7.8.116~/src/Makefile.in    2008-11-18 15:16:56.000000000 -0400
+++ pike7.8-7.8.116/src/Makefile.in     2009-05-04 21:50:17.000000000 -0300
@@ -57,7 +57,7 @@
 # TESTARGS = -F -a
 
 # Arguments for install.pike used by the install targets.
-INSTALLARGS = --new-style
+INSTALLARGS ?= --new-style
 
 #
 # use bison please, yacc isn't good enough.
@@ -658,7 +658,7 @@
        man_prefix="$(man_prefix)" pike_name=$(pike_name) \
        fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
        cflags="@DYNAMIC_MODULE_FLAGS@" ldflags="" \
-       $(INSTALLARGS)
+       include_prefix="$(include_prefix)" $(INSTALLARGS)
 
 install_interactive: pike-complete-stamp tools
        @$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \