Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## 20_build_fixes.dpatch by Magnus Holmgren <magnus@kibibyte.se>
3
##
4
## DP: Fix minor errors in makefile and configuration script
5
 
6
@DPATCH@
7
 
8
--- pmk-0.10.1.orig/Makefile.pmk
9
+++ pmk-0.10.1/Makefile.pmk
10
@@ -52,7 +52,7 @@
11
 #
12
 # list of generated files
13
 #
14
-GEN_FILES=	Makefile Makefile compat/config.h
15
+GEN_FILES=	Makefile tests/Makefile compat/config.h
16
 
17
 #
18
 # source dependency lists
19
--- pmk-0.10.1.orig/pmkcfg.sh
20
+++ pmk-0.10.1/pmkcfg.sh
21
@@ -406,7 +406,7 @@
22
 	fi
23
 	mkf_sed 'CONFDIR' '$(SYSCONFDIR)/pmk'
24
 	mkf_sed 'SBINDIR' '$(PREFIX)/sbin'
25
-	mkf_sed 'DATADIR' '$(PREFIX)/share/$(PREMAKE)'
26
+	mkf_sed 'DATADIR' '$(PREFIX)/share/pmk'
27
 fi
28
 
29
 mkf_sed 'BINDIR' '$(PREFIX)/bin'