Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 2 Rev 4
1
#! /bin/sh /usr/share/dpatch/dpatch-run
1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## 20_build_fixes.dpatch by Magnus Holmgren <magnus@kibibyte.se>
2
## 20_build_fixes.dpatch by Magnus Holmgren <magnus@kibibyte.se>
3
##
3
##
4
## DP: Fix minor errors in makefile and configuration script
4
## DP: Fix minor errors in makefile and configuration script
5
5
6
@DPATCH@
6
@DPATCH@
7
7
8
--- pmk-0.10.1.orig/Makefile.pmk
8
--- pmk-0.10.1.orig/Makefile.pmk
9
+++ pmk-0.10.1/Makefile.pmk
9
+++ pmk-0.10.1/Makefile.pmk
10
@@ -52,7 +52,7 @@
10
@@ -52,7 +52,7 @@
11
 #
11
 #
12
 # list of generated files
12
 # list of generated files
13
 #
13
 #
14
-GEN_FILES=	Makefile Makefile compat/config.h
14
-GEN_FILES=	Makefile Makefile compat/config.h
15
+GEN_FILES=	Makefile tests/Makefile compat/config.h
15
+GEN_FILES=	Makefile tests/Makefile compat/config.h
16
 
16
 
17
 #
17
 #
18
 # source dependency lists
18
 # source dependency lists
19
--- pmk-0.10.1.orig/pmkcfg.sh
19
--- pmk-0.10.1.orig/pmkcfg.sh
20
+++ pmk-0.10.1/pmkcfg.sh
20
+++ pmk-0.10.1/pmkcfg.sh
21
@@ -406,7 +406,7 @@
21
@@ -406,7 +406,7 @@
22
 	fi
22
 	fi
23
 	mkf_sed 'CONFDIR' '$(SYSCONFDIR)/pmk'
23
 	mkf_sed 'CONFDIR' '$(SYSCONFDIR)/pmk'
24
 	mkf_sed 'SBINDIR' '$(PREFIX)/sbin'
24
 	mkf_sed 'SBINDIR' '$(PREFIX)/sbin'
25
-	mkf_sed 'DATADIR' '$(PREFIX)/share/$(PREMAKE)'
25
-	mkf_sed 'DATADIR' '$(PREFIX)/share/$(PREMAKE)'
26
+	mkf_sed 'DATADIR' '$(PREFIX)/share/pmk'
26
+	mkf_sed 'DATADIR' '$(PREFIX)/share/pmk'
27
 fi
27
 fi
28
 
28
 
29
 mkf_sed 'BINDIR' '$(PREFIX)/bin'
29
 mkf_sed 'BINDIR' '$(PREFIX)/bin'