Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
--- prayer-1.0.18.orig/prayer/dirlist.c
2
+++ prayer-1.0.18/prayer/dirlist.c
3
@@ -172,7 +172,8 @@
4
 
5
     dl->next = NIL;
6
     dl->name = pool_strdup(callback.pool, name);
7
-    dl->isdir = (attributes & LATT_NOINFERIORS) ? NIL : T;
8
+    dl->isdir = (attributes & (LATT_NOINFERIORS | LATT_HASNOCHILDREN)) ?
9
+               NIL : T;
10
 
11
     /* Insertion sort algorithm */
12