?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Rev 47 |
Blame |
Compare with Previous |
Last modification |
View Log
| RSS feed
--- a/lib/mydb_db3.c
+++ b/lib/mydb_db3.c
@@ -289,9 +289,6 @@ static int myarchive(const char **fnames
const char **fname;
char dstname[1024], *dp;
- strcpy(dstname, dirname);
- dp = dstname + strlen(dstname);
-
/* Get the list of log files to remove. */
r = log_archive(dbenv, &list, DB_ARCH_ABS, NULL);
if (r) {
@@ -312,6 +309,11 @@ static int myarchive(const char **fnames
free (begin);
}
+ if (!dirname) return 0;
+
+ strcpy(dstname, dirname);
+ dp = dstname + strlen(dstname);
+
/* Get the list of database files to archive. */
/* XXX Should we do this, or just use the list given to us? */
r = log_archive(dbenv, &list, DB_ARCH_ABS | DB_ARCH_DATA, NULL);
--- a/lib/ssl.c
+++ b/lib/ssl.c
@@ -837,6 +837,7 @@ int ssl_prune_sessions(struct ssl_config
log_debug("tls_prune: purged %d out of %d entries",
prock.deletions, prock.count);
+ DB->archive(NULL, NULL);
DB->done();
return (0);