?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Rev 52 |
Blame |
Compare with Previous |
Last modification |
View Log
| RSS feed
--- a/cmd/cmd_welcome.c
+++ b/cmd/cmd_welcome.c
@@ -74,12 +74,7 @@ void cmd_welcome(struct session *session
unsigned long msgno;
if ((request->method != POST) && (prefs->use_welcome)) {
- if (config->welcome_path &&
- (string = read_welcome(request->pool, config->welcome_path)))
- generate_welcome_page(session, string);
- else
- session_redirect(session, request, "list");
-
+ generate_welcome_page(session, NULL);
return;
}
--- a/files/etc/prayer.cf.SRC
+++ b/files/etc/prayer.cf.SRC
@@ -402,12 +402,6 @@ ssl_required = FALSE
# Session banner (local HTML inserted into each page of login session)
#session_banner_path = "$prefix/etc/session_banner.html"
-# Welcome text displayed when user first logs in
-welcome_path = "$prefix/etc/welcome.html"
-
-# Location of help files
-help_dir = "$prefix/help"
-
# Location of icon files
icon_dir = "$prefix/icons"
--- a/shared/config.c
+++ b/shared/config.c
@@ -2139,7 +2139,6 @@ BOOL config_check(struct config * config
struct config_http_port *chp;
char hostname[MAX_ADDRESS+1], domainname[MAX_ADDRESS+1];
- TEST_STRING(config->help_dir, "help_dir");
TEST_STRING(config->icon_dir, "icon_dir");
TEST_STRING(config->socket_dir, "socket_dir");
TEST_STRING(config->init_socket_name, "init_socket_name");