Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 46 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
46 magnus 1
--- a/lib/template.c
2
+++ b/lib/template.c
3
@@ -199,10 +199,11 @@ template_find(char *set, char *name, str
4
     unsigned long first, last, middle;
5
     int rc;
6
 
7
-    while (strcmp(tmi->name, set) != 0)
8
+    while (strcmp(tmi->name, set) != 0) {
9
         tmi++;
10
-    if (!tmi->name)
11
-        return(NIL);
12
+        if (!tmi->name)
13
+            return(NIL);
14
+    }
15
 
16
     tm    = tmi->template_map;
17
     count = *(tmi->count);
18
--- a/shared/config.c
19
+++ b/shared/config.c
20
@@ -168,7 +168,7 @@ struct config *config_create(void)
21
     config->fatal_dump_core = NIL;
22
 
23
     config->template_path = "../templates";
24
-    config->template_set  = "html4";
25
+    config->template_set  = "xhtml_strict";
26
     config->template_use_compiled = T;
27
 
28
     config->prayer_user = NIL;