Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 80 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
12 magnus 1
--- a/files/etc/prayer-accountd.cf
2
+++ b/files/etc/prayer-accountd.cf
15 magnus 3
@@ -8,6 +8,10 @@
3 magnus 4
 # Default accountd.cf file suitable for RedHat Linux only.
5
 # See distribution for some sample files for FreeBSD and Solaris
6
 
7
+accountd_port = 145
8
+
15 magnus 9
+authtype = pam
10
+
3 magnus 11
 msforward_name      = ".MSforward"
12
 forward_name        = ".forward"
13
 aliases_name        = "vacation.aliases"
12 magnus 14
--- a/files/Makefile
15
+++ b/files/Makefile
49 magnus 16
@@ -65,21 +65,16 @@ install-aconfig:
3 magnus 17
 
18
 install-motd:
19
        $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
20
-       etc/motd.html ${BROOT}${PREFIX}/etc
23 magnus 21
+       etc/motd.html ${BROOT}/etc/prayer
3 magnus 22
 
23
 install:
44 magnus 24
-       PREFIX=$(BROOT)$(PREFIX) VAR_PREFIX=$(BROOT)$(VAR_PREFIX) \
25
-       RO_USER=$(RO_USER) RO_GROUP=$(RO_GROUP) \
26
-       RW_USER=$(RW_USER) RW_GROUP=$(RW_GROUP) \
27
-       PUBLIC_DIR=$(PUBLIC_DIR) PRIVATE_DIR=$(PRIVATE_DIR) \
28
-       PUBLIC_FILE=$(PUBLIC_FILE) PRIVATE_FILE=$(PRIVATE_FILE) \
29
-       PUBLIC_EXEC=$(PUBLIC_FILE) PRIVATE_EXEC=$(PRIVATE_EXEC) \
30
-       BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \
31
-       ./install.sh
32
-       if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi
23 magnus 33
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}${PREFIX}
34
+       ${INSTALL} -d -o ${RO_USER} -g ${RO_GROUP} -m ${PUBLIC_DIR} ${BROOT}/etc/prayer
3 magnus 35
+
44 magnus 36
+       tar -c --owner ${RO_USER} --group ${RO_GROUP} icons static | tar -C ${BROOT}${PREFIX} -x
23 magnus 37
        if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi
38
        if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi
3 magnus 39
-       if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi
23 magnus 40
+       if [ ! -f $(BROOT)/etc/prayer/motd.html ]; then $(MAKE) install-motd; fi
3 magnus 41
 
42
 redhat-install-init.d:
43
        install -D -o root -g root -m 755 \
12 magnus 44
--- a/files/etc/prayer.cf.SRC
45
+++ b/files/etc/prayer.cf.SRC
5 magnus 46
@@ -20,7 +20,7 @@ var_prefix  = "__VAR_PREFIX__"
3 magnus 47
 # User ID to run as if we start off as root
48
 prayer_user           = "prayer"
49
 # Group ID to run as if we start off as root
50
-prayer_group          = "prayer"
51
+prayer_group          = "nogroup"
52
 
53
 # Run prayer as background process.
54
 #   TRUE => will return as soon as valid configuration is found.
80 magnus 55
@@ -53,7 +53,7 @@ directory_perms       = 0750
56
 imapd_user_map      = ""
57
 
58
 # Default imapd server.
59
-imapd_server        = localhost
60
+imapd_server        = localhost/notls
61
 
62
 # Name of Prayer user preferences file on IMAP server
63
 prefs_folder_name   = ".prayer"
48 magnus 64
@@ -266,11 +266,11 @@ http_icon_embed   = TRUE
3 magnus 65
 
35 magnus 66
 # Locatation of SSL certificate file (only used if SSL ports defined).
67
 # Required if we are going to provide SSL services.
68
-ssl_cert_file       = "$prefix/certs/prayer.pem"
69
+ssl_cert_file       = "/etc/ssl/certs/ssl-cert-snakeoil.pem"
70
 
71
 # Locatation of SSL private key file (only used if SSL ports defined).
72
 # Required if we are going to provide SSL services.
73
-ssl_privatekey_file = "$prefix/certs/prayer.pem"
74
+ssl_privatekey_file = "/etc/ssl/private/ssl-cert-snakeoil.key"
75
 
76
 # Master server will regenerate shared RSA key at this interval:
77
 ssl_rsakey_lifespan = 15m
48 magnus 78
@@ -278,26 +278,14 @@ ssl_rsakey_lifespan = 15m
35 magnus 79
 # RSA key remains fresh in child process for this long after first actual use.
80
 ssl_rsakey_freshen  = 15m
81
 
82
-# SSL session cache timeout.
83
-ssl_session_timeout = 24h
84
+# SSL session cache timeout. Uncomment to enable SSL session caching.
85
+# You should also arrange for prayer-ssl-prune to be run periodically.
86
+#ssl_session_timeout = 24h
87
 
88
 # EGD socket, if system has no /dev/urandom
89
 #egd_socket = "/var/prngd/urandom"
90
 
91
 ######################################################################
92
-
93
-# Direct connection stuff. Experimental! Leave this well alone unless you
94
-# understand what it is for (DESIGN document provides detail for the curious).
95
-direct_enable       = FALSE
96
-
97
-# Following four options just define a set of (non-overlapping) ports for
98
-# SSL and plaintext use if direct connection mode is enabled.
99
-direct_ssl_first    = 5000
100
-direct_ssl_count    = 1000
101
-direct_plain_first  = 4000
102
-direct_plain_count  = 1000
103
-
104
-######################################################################
105
 # Session specific configuration
106
 
107
 # Session switches to idle mode after this much time: connections to IMAP
48 magnus 108
@@ -382,13 +370,13 @@ ispell_path         = /usr/bin/ispell
35 magnus 109
 #  <login_suffix_path>
110
 
111
 # Login page prefix
112
-#login_prefix_path   = "$prefix/etc/login_prefix.html"
113
+#login_prefix_path   = "/etc/login_prefix.html"
114
 
115
 # Message of the day file
116
-#motd_path           = "$prefix/etc/motd.html"
79 magnus 117
+#motd_path           = "/etc/prayer/motd.html"
35 magnus 118
 
119
 # Login page suffix
120
-#login_suffix_path   = "$prefix/etc/login_suffix.html"
121
+#login_suffix_path   = "/etc/login_suffix.html"
122
 
123
 # Login security: Prayer's front page defaults to a login form.
124
 # If the user does not connect via SSL then this can be changed
79 magnus 125
@@ -409,9 +397,6 @@ ssl_required        = FALSE
126
 # Session banner (local HTML inserted into each page of login session)
127
 #session_banner_path = "$prefix/etc/session_banner.html"
35 magnus 128
 
79 magnus 129
-# Location of help files
130
-help_dir            = "$prefix/help"
131
-
132
 # Location of icon files
133
 icon_dir            = "$prefix/icons"
134
 
135
@@ -423,10 +408,11 @@ bin_dir             = "__BIN_DIR__"
136
 
3 magnus 137
 # Various directories used by the running system
138
 # Logs stored in $log_dir
139
-log_dir             = "$var_prefix/logs"
48 magnus 140
+log_dir             = "/var/log/prayer"
3 magnus 141
 
79 magnus 142
 # $lock_dir used for interlocking between prayer processes
143
-lock_dir            = "$var_prefix/locks"
144
+# (only on Debian GNU/kFreeBSD)
145
+lock_dir            = "$var_prefix"
146
 
3 magnus 147
 # $socket_dir is location for unix domain sockets which connect frontend
148
 # to backend in proxy mode of operation.
79 magnus 149
@@ -434,7 +420,7 @@ socket_dir          = "$var_prefix/socke
3 magnus 150
 
151
 # Split socket directory into 64 subdirs keyed on first letter of sessionID
152
 # Code provides compatibility in both directions: can switch back and forward
23 magnus 153
-socket_split_dir    = TRUE
154
+socket_split_dir    = FALSE
3 magnus 155
 
23 magnus 156
 # Name of Unix domain socket (in $socket_dir) used for initial handshake
157
 # between prayer and prayer-session processes when a user logs in
79 magnus 158
@@ -448,7 +434,7 @@ ssl_session_dir     = "$var_prefix/ssl_s
71 magnus 159
 tmp_dir             = "$var_prefix/tmp"
3 magnus 160
 
161
 # Location for PID files for prayer and prayer-session master processes.
162
-pid_dir             = "$var_prefix/pid"
23 magnus 163
+pid_dir             = "$var_prefix"
3 magnus 164
 
165
 # Interface to Hermes finger database
166
 #lookup_rpasswd   = "/data/finger/rpasswd.cdb"
79 magnus 167
@@ -609,14 +595,14 @@ hiersep             = "/"
35 magnus 168
 dualuse             = FALSE
169
 
170
 # Names of postponed_folder and sent_mail_folder, relative to maildir
171
-postponed_folder    = "postponed-msgs"
172
-sent_mail_folder    = "sent-mail"
173
+postponed_folder    = "Drafts"
174
+sent_mail_folder    = "Sent"
175
 
176
 # Default domain for outgoing mail. Defaults to "$hostname".
3 magnus 177
 # default_domain      = "<valid mail domain>"
178
 
179
 # Language for ispell.
180
-ispell_language     = "british"
181
+ispell_language     = "american"
182
 
183
 # Size of small and large compose windows
184
 small_cols          = 80
71 magnus 185
--- a/shared/config.c
186
+++ b/shared/config.c
79 magnus 187
@@ -2139,12 +2139,10 @@ BOOL config_check(struct config * config
188
     struct config_http_port *chp;
189
     char hostname[MAX_ADDRESS+1], domainname[MAX_ADDRESS+1];
190
 
191
-    TEST_STRING(config->help_dir, "help_dir");
192
     TEST_STRING(config->icon_dir, "icon_dir");
71 magnus 193
     TEST_STRING(config->socket_dir, "socket_dir");
194
     TEST_STRING(config->init_socket_name, "init_socket_name");
195
     TEST_STRING(config->ssl_session_dir, "ssl_session_dir");
196
-    TEST_STRING(config->lock_dir, "lock_dir");
197
     TEST_STRING(config->log_dir, "log_dir");
198
     TEST_STRING(config->tmp_dir, "tmp_dir");
199
     TEST_STRING(config->pid_dir, "pid_dir");