Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 37 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
33 magnus 1
Author: Magnus Holmgren <holmgren@debian.org>
2
Description: Pass CFLAGS and LDFLAGS to xmkmf-generated Makefiles
3
 Pass CFLAGS and LDFLAGS through via ./Makefile as
4
 CDEBUGFLAGS and LOCAL_LDFLAGS to vnc_unixsrc/*/Makefile
5
 
32 magnus 6
--- a/Makefile
7
+++ b/Makefile
8
@@ -53,8 +53,8 @@ config:
9
        @echo Now run: "'make all'"
10
 
11
 all:
12
-       cd $(VSRC)/libvncauth; $(MAKE)
13
-       cd $(VSRC)/vncviewer;  $(MAKE)
37 magnus 14
+       cd $(VSRC)/libvncauth; $(MAKE) EXTRA_DEFINES="$(CPPFLAGS)" CDEBUGFLAGS="$(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)"
15
+       cd $(VSRC)/vncviewer;  $(MAKE) EXTRA_DEFINES="$(CPPFLAGS)" CDEBUGFLAGS="$(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)"
32 magnus 16
        if [ "X$(JSRC)" != "X" ]; then cd $(JSRC); $(MAKE); fi
17
        cd $(PSRC); $(MAKE)
18