Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 197 → Rev 198

/trunk/debian/patches/pcre_info_obsolete.patch
File deleted
/trunk/debian/patches/dump_timeout.patch
5,7 → 5,7
 
--- a/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
+++ b/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
@@ -325,7 +325,8 @@ void dump_files() {
@@ -330,7 +330,8 @@ void dump_files() {
#if constant(alarm)
// Dumping shouldn't take more than a minute per file.
/trunk/debian/patches/undefined_htons.patch
2,7 → 2,7
 
--- a/src/modules/_Protocols_DNS_SD/configure.in
+++ b/src/modules/_Protocols_DNS_SD/configure.in
@@ -12,7 +12,7 @@ if test x$with_dnssd = xyes ; then
@@ -11,7 +11,7 @@ if test x$with_dnssd = xyes ; then
PIKE_FEATURE(DNS-SD,[no (dns_sd.h or howl.h not found)])
13,7 → 13,7
PIKE_FEATURE(DNS-SD,[no (libdns_sd not found)])
--- a/src/modules/_Protocols_DNS_SD/sd.c
+++ b/src/modules/_Protocols_DNS_SD/sd.c
@@ -34,6 +34,12 @@
@@ -33,6 +33,12 @@
#include <signal.h>
28,7 → 28,7
#undef THIS
--- a/src/modules/_Protocols_DNS_SD/config.h.in
+++ b/src/modules/_Protocols_DNS_SD/config.h.in
@@ -10,6 +10,9 @@
@@ -9,6 +9,9 @@
#define PROTOCOLS_DNS_SD_H
38,7 → 38,7
/* Define to 1 if you have the <dns_sd.h> header file. */
#undef HAVE_DNS_SD_H
@@ -25,6 +28,9 @@
@@ -24,6 +27,9 @@
/* Define to 1 if you have the <memory.h> header file. */
#undef HAVE_MEMORY_H
50,16 → 50,16
--- a/src/modules/_Protocols_DNS_SD/configure
+++ b/src/modules/_Protocols_DNS_SD/configure
@@ -3077,7 +3077,7 @@ done
@@ -3584,7 +3584,7 @@ done
fi
-for ac_header in dns_sd.h howl.h
+for ac_header in dns_sd.h howl.h netinet/in.h arpa/inet.h
do
do :
@@ -3240,7 +3240,7 @@ fi
@@ -3611,7 +3611,7 @@ fi
done
else
/trunk/debian/patches/dynamic_module_makefile.in-libgcc.patch
3,10 → 3,7
 
--- a/src/modules/dynamic_module_makefile.in
+++ b/src/modules/dynamic_module_makefile.in
@@ -2,6 +2,7 @@
# $Id: b9e7817a07dab41006a9b1cc92c9ce0193303874 $
#
@@ -1,3 +1,4 @@
+LIBGCC=$(shell gcc -print-libgcc-file-name)
LC_REQ=@LC_REQ@
/trunk/debian/patches/precompile_breakage.patch
0,0 → 1,11
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -1357,7 +1357,7 @@ precompile.sh: $(SRCDIR)/precompile.sh.i
# recursive use of make.
precompile.sh-stamp:
@if [ -f precompile.sh ]; then :; else $(MAKE) precompile.sh; fi
- @touch 0101010185 precompile.sh-stamp 2>/dev/null
+ @touch -t 8501010101 precompile.sh-stamp 2>/dev/null
$(SRCDIR)/machine.h.in: $(SRCDIR)/stamp-h.in
@if test -f $(SRCDIR)/machine.h.in; then :; else \
/trunk/debian/patches/misplaced_MAXPATHLEN.patch
1,9 → 1,9
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
Subject: Move reserve MAXPATHLEN definition up.
 
--- a/src/modules/files/efuns.c
+++ b/src/modules/files/efuns.c
@@ -118,6 +118,10 @@ LINKFUNC(BOOL, movefileex, (
--- a/src/modules/_Stdio/efuns.c
+++ b/src/modules/_Stdio/efuns.c
@@ -89,6 +89,10 @@ LINKFUNC(BOOL, movefileex, (
#endif /* __NT__ */
14,7 → 14,7
struct array *encode_stat(PIKE_STAT_T *s)
{
struct array *a;
@@ -1524,9 +1528,6 @@ void f_getcwd(INT32 args)
@@ -1466,9 +1470,6 @@ void f_getcwd(INT32 args)
size*=2;
} while (size < 10000);
#else
/trunk/debian/patches/pthread_stub.patch
1,7 → 1,7
--- a/src/configure
+++ b/src/configure
@@ -90980,6 +90980,9 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
@@ -69299,6 +69299,9 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <pthread.h>
+#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork)
12,7 → 12,7
int
--- a/src/configure.in
+++ b/src/configure.in
@@ -4014,6 +4014,9 @@ pthread_t gazonk;
@@ -4062,6 +4062,9 @@ pthread_t gazonk;
AC_MSG_CHECKING(for pthread_atfork)
AC_CACHE_VAL(pike_cv_have_pthread_atfork,[
AC_TRY_LINK([#include <pthread.h>
/trunk/debian/patches/no_dump_modules.patch
3,7 → 3,7
 
--- a/bin/install.pike
+++ b/bin/install.pike
@@ -2980,7 +2980,6 @@ the PRIVATE_CRT stuff in install.pike.\n
@@ -2988,7 +2988,6 @@ the PRIVATE_CRT stuff in install.pike.\n
{
do_export();
}else{
/trunk/debian/patches/series
9,6 → 9,6
unbreak_cross_compilation.patch
dump_timeout.patch
hurd.patch
pcre_info_obsolete.patch
undefined_htons.patch
bad_size_t_redef.patch
precompile_breakage.patch
/trunk/debian/patches/unbreak_cross_compilation.patch
8,7 → 8,7
@DPATCH@
--- a/src/configure
+++ b/src/configure
@@ -8037,7 +8037,7 @@ if test "x$enable_binary" = "xno"; then
@@ -7999,7 +7999,7 @@ if test "x$enable_binary" = "xno"; then
RUNPIKE="USE_PIKE"
RUNTPIKE="USE_PIKE"
elif test "x$cross_compiling" = "xyes"; then
17,12 → 17,12
RUNTPIKE="USE_PIKE"
else
RUNPIKE="DEFAULT_RUNPIKE"
@@ -106079,7 +106079,7 @@ EOF
@@ -80177,7 +80177,7 @@ EOF
;;
esac
if test "$cross_compiling" = yes; then
if test "$cross_compiling" = yes; then :
- pike_cv_sys_dynamic_loading=no
+ pike_cv_sys_dynamic_loading=yes
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
/trunk/debian/patches/module-layout.patch
3,7 → 3,7
 
--- a/lib/master.pike.in
+++ b/lib/master.pike.in
@@ -2137,6 +2137,10 @@ protected void create()
@@ -2271,6 +2271,10 @@ protected void create()
add_module_path("#lib_prefix#/modules");
#endif
16,7 → 16,7
#endif
--- a/lib/modules/Tools.pmod/Standalone.pmod/module.pike
+++ b/lib/modules/Tools.pmod/Standalone.pmod/module.pike
@@ -25,9 +25,8 @@ string bin_path=include_path;
@@ -23,9 +23,8 @@ string bin_path=include_path;
// this is not the ideal location for all systems, but it's a start.
string local_module_path=combine_path(getenv("HOME")||"","lib/pike/modules");
bool old_style_module = false;
28,7 → 28,7
// where do we install the documentation?
string system_doc_path = master()->doc_prefix;
@@ -184,7 +183,7 @@ void do_make(array(string) cmd)
@@ -182,7 +181,7 @@ void do_make(array(string) cmd)
extra_args = ({
"PIKE="+run_pike,
"SRCDIR="+fix("$src"),
37,7 → 37,7
"LOCAL_MODULE_PATH=" + lmp,
});
}
@@ -241,6 +240,7 @@ int main(int argc, array(string) argv)
@@ -239,6 +238,7 @@ int main(int argc, array(string) argv)
({"all",Getopt.NO_ARG,({"--all"}) }),
({"make",Getopt.NO_ARG,({"--make"}) }),
({"auto",Getopt.NO_ARG,({"--auto"}) }),
45,7 → 45,7
({"source",Getopt.HAS_ARG,({"--source"}) }),
({"query",Getopt.HAS_ARG,({"--query"}) }),
({"config_args",Getopt.HAS_ARG,({"--configure-args"}) }),
@@ -277,6 +277,9 @@ int main(int argc, array(string) argv)
@@ -275,6 +275,9 @@ int main(int argc, array(string) argv)
case "auto":
run->depend=run->autoheader=run->autoconf=run->configure=run->make=AUTO;
break;
55,7 → 55,7
}
}
@@ -421,7 +424,7 @@ int main(int argc, array(string) argv)
@@ -419,7 +422,7 @@ int main(int argc, array(string) argv)
run_or_fail( ([ "env":getenv()|
([
"PIKE":run_pike,
66,7 → 66,7
]),
--- a/src/modules/dynamic_module_makefile.in
+++ b/src/modules/dynamic_module_makefile.in
@@ -90,13 +90,13 @@ $(OBJS): propagated_variables
@@ -86,13 +86,13 @@ $(OBJS): propagated_variables
#
install: $(MODULE_INSTALL)
@if test "x$(OBJS)" != "x" ; then \
/trunk/debian/patches/hurd.patch
6,7 → 6,7
 
--- a/src/modules/system/system.c
+++ b/src/modules/system/system.c
@@ -411,6 +411,13 @@ void f_resolvepath(INT32 args)
@@ -412,6 +412,13 @@ void f_resolvepath(INT32 args)
#endif /* ENAMETOOLONG */
(len >= buflen - 1));
#elif defined(HAVE_REALPATH)
20,7 → 20,7
buflen = PATH_MAX+1;
if (!(buf = alloca(buflen))) {
@@ -420,6 +427,7 @@ void f_resolvepath(INT32 args)
@@ -421,6 +428,7 @@ void f_resolvepath(INT32 args)
if ((buf = realpath(path, buf))) {
len = strlen(buf);
}
28,7 → 28,7
#else /* !HAVE_RESOLVEPATH && !HAVE_REALPATH */
#error "f_resolvepath with neither resolvepath nor realpath."
#endif /* HAVE_RESOLVEPATH */
@@ -429,6 +437,9 @@ void f_resolvepath(INT32 args)
@@ -430,6 +438,9 @@ void f_resolvepath(INT32 args)
}
pop_n_elems(args);
push_string(make_shared_binary_string(buf, len));
40,7 → 40,7
--- a/src/pike_threadlib.h
+++ b/src/pike_threadlib.h
@@ -94,6 +94,9 @@ PMOD_EXPORT extern struct program *threa
@@ -88,6 +88,9 @@
#ifdef HAVE_MACH_TASK_INFO_H
#include <mach/task_info.h>
#endif
52,7 → 52,7
#endif
--- a/src/configure.in
+++ b/src/configure.in
@@ -3308,7 +3308,7 @@ AC_CHECK_HEADERS(winsock2.h sys/rusage.h
@@ -3351,7 +3351,7 @@ AC_CHECK_HEADERS(winsock2.h sys/rusage.h
float.h sys/priocntl.h sys/sched.h winbase.h errno.h \
stddef.h mmx.h asm/mmx.h sys/termio.h sys/termios.h \
ws2tcpip.h valgrind/memcheck.h memcheck.h valgrind.h \
60,8 → 60,8
+ sys/prctl.h sys/ioctl.h mach/message.h mach/task_info.h mach/task.h \
mach/mach_init.h syscall.h sys/syscall.h devices/timer.h \
direct.h CoreServices/CoreServices.h execinfo.h \
mach/mach.h mach/thread_act.h mach/clock.h,,,[
@@ -7933,7 +7933,7 @@ if test -z "$LDSHARED" ; then
mach/mach.h mach/thread_act.h mach/clock.h urcu.h,,,[
@@ -8063,7 +8063,7 @@ if test -z "$LDSHARED" ; then
next*) LDSHARED="$REALCC $CFLAGS -nostdlib -r";;
Linux*) LDSHARED="$REALCC -shared";;
GNU/kFreeBSD*) LDSHARED="$REALCC -shared";;
72,7 → 72,7
OpenBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
--- a/src/configure
+++ b/src/configure
@@ -79597,7 +79597,7 @@ for ac_header in winsock2.h sys/rusage.h
@@ -65135,7 +65135,7 @@ fi
float.h sys/priocntl.h sys/sched.h winbase.h errno.h \
stddef.h mmx.h asm/mmx.h sys/termio.h sys/termios.h \
ws2tcpip.h valgrind/memcheck.h memcheck.h valgrind.h \
80,8 → 80,8
+ sys/prctl.h sys/ioctl.h mach/message.h mach/task_info.h mach/task.h \
mach/mach_init.h syscall.h sys/syscall.h devices/timer.h \
direct.h CoreServices/CoreServices.h execinfo.h \
mach/mach.h mach/thread_act.h mach/clock.h
@@ -79746,7 +79746,7 @@ done
mach/mach.h mach/thread_act.h mach/clock.h urcu.h
@@ -65238,7 +65238,7 @@ done
float.h sys/priocntl.h sys/sched.h winbase.h errno.h \
stddef.h mmx.h asm/mmx.h sys/termio.h sys/termios.h \
ws2tcpip.h valgrind/memcheck.h memcheck.h valgrind.h \
89,8 → 89,8
+ sys/prctl.h sys/ioctl.h mach/message.h mach/task_info.h mach/task.h \
mach/mach_init.h syscall.h sys/syscall.h devices/timer.h \
direct.h CoreServices/CoreServices.h execinfo.h \
mach/mach.h mach/thread_act.h mach/clock.h
@@ -104594,7 +104594,7 @@ if test -z "$LDSHARED" ; then
mach/mach.h mach/thread_act.h mach/clock.h urcu.h
@@ -79010,7 +79010,7 @@ if test -z "$LDSHARED" ; then
next*) LDSHARED="$REALCC $CFLAGS -nostdlib -r";;
Linux*) LDSHARED="$REALCC -shared";;
GNU/kFreeBSD*) LDSHARED="$REALCC -shared";;
101,7 → 101,7
OpenBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
--- a/src/machine.h.in
+++ b/src/machine.h.in
@@ -875,6 +875,9 @@
@@ -971,6 +971,9 @@
/* Define to 1 if you have the <mach/mach_init.h> header file. */
#undef HAVE_MACH_MACH_INIT_H
/trunk/debian/patches/smartlink_rpath.patch
18,7 → 18,7
if test x$LINKING != xno -a "x$RPATH" != x ; then
--- a/src/smartlink.c
+++ b/src/smartlink.c
@@ -160,7 +160,7 @@ int main(int argc, char **argv)
@@ -162,7 +162,7 @@ int main(int argc, char **argv)
full_rpath = rpath;
#ifdef USE_Wl
27,7 → 27,7
#elif defined(USE_Wl_R)
strcat(rpath, "-Wl,-R");
#elif defined(USE_R)
@@ -310,7 +310,7 @@ int main(int argc, char **argv)
@@ -312,7 +312,7 @@ int main(int argc, char **argv)
}
rpath_in_use |= add_path(rpath, ld_lib_path);
}
36,7 → 36,7
if (rpath_in_use) {
/* Delete the terminating ':' */
rpath[strlen(rpath) - 1] = 0;
@@ -357,6 +357,7 @@ int main(int argc, char **argv)
@@ -359,6 +359,7 @@ int main(int argc, char **argv)
#error Unknown method
#endif
}
/trunk/debian/patches/bad_size_t_redef.patch
5,7 → 5,7
 
--- a/src/modules/_Image_JPEG/transupp.c
+++ b/src/modules/_Image_JPEG/transupp.c
@@ -36,17 +36,7 @@
@@ -35,17 +35,7 @@
* of internals, and added inclusion of jerror.h
*/